# Wowza failed after 10 days - java.lang.OutOfMemoryError: Java heap space

**URL:** https://community.wowza.com/t/wowza-failed-after-10-days-java-lang-outofmemoryerror-java-heap-space/33720
**Category:** Wowza Streaming Engine
**Created:** [April 5, 2013, 11:59am UTC](https://community.wowza.com/t/wowza-failed-after-10-days-java-lang-outofmemoryerror-java-heap-space/33720 "2013-04-05T11:59:06Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![eduardo\_espinoza\_sua](https://avatars.discourse-cdn.com/v4/letter/e/54ee81/32.png) [@eduardo\_espinoza\_sua](https://community.wowza.com/u/eduardo_espinoza_sua)
#### Post date: [April 5, 2013, 11:59am UTC](https://community.wowza.com/t/wowza-failed-after-10-days-java-lang-outofmemoryerror-java-heap-space/33720/1 "2013-04-05T11:59:06Z")

</div>

Good day

I would like to request help about what else to do with my wms installation

My current wms was working ok round 10 days.

wms was tunned using guides at forum.

Thanks in advance for any help

Here information

**Server info:**

model name : Intel® Core™ i7 CPU 870 @ 2.93GHz

# of Cores 4

# of Threads 8

RAM: 16

**Inbound streams**

297

**sevenv.sh**

```auto
#!/bin/sh
_EXECJAVA=java
set JAVA_OPTS="-server -Xmx8000M"
# Uncomment to run server environment (faster), Note: will only work if server VM install, comes with JDL
JAVA_OPTS="$JAVA_OPTS -server"
# Can be a better GC setting to avoid long pauses
JAVA_OPTS="$JAVA_OPTS -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:+UseParNewGC -XX:NewSize=512m"
# Uncomment to force Java to use specific language settings
#JAVA_OPTS="$JAVA_OPTS -Duser.language=en -Duser.country=US"
# Uncomment to fix multicast crosstalk problem when streams share multicast port
JAVA_OPTS="$JAVA_OPTS -Djava.net.preferIPv4Stack=true"
WMSAPP_HOME=/usr/local/WowzaMediaServer
WMSCONFIG_HOME=/usr/local/WowzaMediaServer
WMSCONFIG_URL=
export WMSAPP_HOME WMSCONFIG_HOME JAVA_OPTS _EXECJAVA

```

**VHost.xml**

```auto
<Root>
	<VHost>
		<HostPortList>
			<HostPort>
				<ProcessorCount>16</ProcessorCount>
				<IpAddress>*</IpAddress>
				<!-- Separate multiple ports with commas -->
				<!-- 80: HTTP, RTMPT -->
				<!-- 554: RTSP -->
				<Port>1935,554</Port>
				<SocketConfiguration>
					<ReuseAddress>true</ReuseAddress>
					<!-- suggested settings for video on demand applications -->
					<ReceiveBufferSize>24000</ReceiveBufferSize>
					<SendBufferSize>65000</SendBufferSize>
					<!-- suggest settings for low latency chat and video recording applications
					<ReceiveBufferSize>16000</ReceiveBufferSize>
					<SendBufferSize>16000</SendBufferSize>
					-->
					<KeepAlive>true</KeepAlive>
					<!-- <TrafficClass>0</TrafficClass> -->
					<!-- <OobInline>false</OobInline> -->
					<!-- <SoLingerTime>-1</SoLingerTime> -->
					<!-- <TcpNoDelay>false</TcpNoDelay> -->
					<AcceptorBackLog>100</AcceptorBackLog>
				</SocketConfiguration>
				<HTTPStreamerAdapterIDs>cupertinostreaming,smoothstreaming,sanjosestreaming,dvrchunkstreaming</HTTPStreamerAdapterIDs>
				<HTTPProviders>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.HTTPCrossdomain</BaseClass>
						<RequestFilters>*crossdomain.xml</RequestFilters>
						<AuthenticationMethod>none</AuthenticationMethod>
					</HTTPProvider>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.HTTPClientAccessPolicy</BaseClass>
						<RequestFilters>*clientaccesspolicy.xml</RequestFilters>
						<AuthenticationMethod>none</AuthenticationMethod>
					</HTTPProvider>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.HTTPServerVersion</BaseClass>
						<RequestFilters>*</RequestFilters>
						<AuthenticationMethod>none</AuthenticationMethod>
					</HTTPProvider>
				</HTTPProviders>
			</HostPort>
			
			<!-- 443 with SSL -->
			<!--
			<HostPort>
				<ProcessorCount>16</ProcessorCount>
				<IpAddress>*</IpAddress>
				<Port>443</Port>
				<SSLConfig>
					<KeyStorePath>${com.wowza.wms.context.VHostConfigHome}/conf/keystore.cert</KeyStorePath>
					<KeyStorePassword>[password]</KeyStorePassword>
					<KeyStoreType>JKS</KeyStoreType>
					<SSLProtocol>TLS</SSLProtocol>
					<Algorithm>SunX509</Algorithm>
					<CipherSuites></CipherSuites>
					<Protocols></Protocols>
				</SSLConfig>
				<SocketConfiguration>
					<ReuseAddress>true</ReuseAddress>
					<ReceiveBufferSize>24000</ReceiveBufferSize>
					<SendBufferSize>65000</SendBufferSize>
					<KeepAlive>true</KeepAlive>
					<AcceptorBackLog>100</AcceptorBackLog>
				</SocketConfiguration>
				<HTTPStreamerAdapterIDs>cupertinostreaming,smoothstreaming,sanjosestreaming,dvrchunkstreaming</HTTPStreamerAdapterIDs>
				<HTTPProviders>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.HTTPClientAccessPolicy</BaseClass>
						<RequestFilters>*clientaccesspolicy.xml</RequestFilters>
						<AuthenticationMethod>none</AuthenticationMethod>
					</HTTPProvider>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.HTTPCrossdomain</BaseClass>
						<RequestFilters>*crossdomain.xml</RequestFilters>
						<AuthenticationMethod>none</AuthenticationMethod>
					</HTTPProvider>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.HTTPServerVersion</BaseClass>
						<RequestFilters>*</RequestFilters>
						<AuthenticationMethod>none</AuthenticationMethod>
					</HTTPProvider>
				</HTTPProviders>
			</HostPort>
			-->
			
			<!-- Admin HostPort -->
			<HostPort>
				<ProcessorCount>1</ProcessorCount>
				<IpAddress>*</IpAddress>
				<Port>8086</Port>
				<SocketConfiguration>
					<ReuseAddress>true</ReuseAddress>
					<ReceiveBufferSize>16000</ReceiveBufferSize>
					<SendBufferSize>16000</SendBufferSize>
					<KeepAlive>true</KeepAlive>
					<AcceptorBackLog>100</AcceptorBackLog>
				</SocketConfiguration>
				<HTTPStreamerAdapterIDs></HTTPStreamerAdapterIDs>
				<HTTPProviders>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.streammanager.HTTPStreamManager</BaseClass>
						<RequestFilters>streammanager*</RequestFilters>
						<AuthenticationMethod>admin-digest</AuthenticationMethod>
					</HTTPProvider>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.HTTPServerInfoXML</BaseClass>
						<RequestFilters>serverinfo*</RequestFilters>
						<AuthenticationMethod>admin-digest</AuthenticationMethod>
					</HTTPProvider>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.HTTPConnectionInfo</BaseClass>
						<RequestFilters>connectioninfo*</RequestFilters>
						<AuthenticationMethod>admin-digest</AuthenticationMethod>
					</HTTPProvider>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.HTTPConnectionCountsXML</BaseClass>
						<RequestFilters>connectioncounts*</RequestFilters>
						<AuthenticationMethod>none</AuthenticationMethod>
					</HTTPProvider>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.transcoder.httpprovider.HTTPTranscoderThumbnail</BaseClass>
						<RequestFilters>transcoderthumbnail*</RequestFilters>
						<AuthenticationMethod>admin-digest</AuthenticationMethod>
					</HTTPProvider>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.HTTPProviderMediaList</BaseClass>
						<RequestFilters>medialist*</RequestFilters>
						<AuthenticationMethod>admin-digest</AuthenticationMethod>
					</HTTPProvider>
					<HTTPProvider>
						<BaseClass>com.wowza.wms.http.HTTPServerVersion</BaseClass>
						<RequestFilters>*</RequestFilters>
						<AuthenticationMethod>none</AuthenticationMethod>
					</HTTPProvider>
				</HTTPProviders>
			</HostPort>
		
		</HostPortList>
		
		<HTTPStreamerAdapters>
			<HTTPStreamerAdapter>
				<ID>smoothstreaming</ID>
				<Name>smoothstreaming</Name>
				<Properties>
				</Properties>
			</HTTPStreamerAdapter>
			<HTTPStreamerAdapter>
				<ID>cupertinostreaming</ID>
				<Name>cupertinostreaming</Name>
				<Properties>
				</Properties>
			</HTTPStreamerAdapter>
			<HTTPStreamerAdapter>
				<ID>sanjosestreaming</ID>
				<Name>sanjosestreaming</Name>
				<Properties>
				</Properties>
			</HTTPStreamerAdapter>
			<HTTPStreamerAdapter>
				<ID>dvrchunkstreaming</ID>
				<Name>dvrchunkstreaming</Name>
				<Properties>
				</Properties>
			</HTTPStreamerAdapter>
		</HTTPStreamerAdapters>
		<HandlerThreadPool>
			<PoolSize>480</PoolSize>
		</HandlerThreadPool>
		<TransportThreadPool>
			<PoolSize>320</PoolSize>
		</TransportThreadPool>
		<IdleWorkers>
			<WorkerCount>16</WorkerCount>
			<CheckFrequency>50</CheckFrequency>
			<MinimumWaitTime>5</MinimumWaitTime>
		</IdleWorkers>
		<NetConnections>
			<ProcessorCount>16</ProcessorCount>
			<IdleFrequency>250</IdleFrequency>
			<SocketConfiguration>
				<ReuseAddress>true</ReuseAddress>
				<ReceiveBufferSize>65000</ReceiveBufferSize>
				<SendBufferSize>24000</SendBufferSize>
				<KeepAlive>true</KeepAlive>
				<!-- <TrafficClass>0</TrafficClass> -->
				<!-- <OobInline>false</OobInline> -->
				<!-- <SoLingerTime>-1</SoLingerTime> -->
				<!-- <TcpNoDelay>false</TcpNoDelay> -->
				<AcceptorBackLog>100</AcceptorBackLog>
			</SocketConfiguration>
		</NetConnections>
		<HTTPTunnel>
			<KeepAliveTimeout>2000</KeepAliveTimeout>
		</HTTPTunnel>
		<Client>
			<ClientTimeout>90000</ClientTimeout>
			<IdleFrequency>250</IdleFrequency>
		</Client>
		<!-- RTP/Authentication/Methods defined in Authentication.xml. Default setup includes; none, basic, digest -->
		<RTP>
			<IdleFrequency>75</IdleFrequency>
			<DatagramConfiguration>
				<Incoming>
					<ReuseAddress>true</ReuseAddress>
					<ReceiveBufferSize>1024000</ReceiveBufferSize>
					<SendBufferSize>65000</SendBufferSize>
					<!-- <MulticastBindToAddress>true</MulticastBindToAddress> -->
					<!-- <MulticastInterfaceAddress>192.168.1.22</MulticastInterfaceAddress> -->
					<!-- <TrafficClass>0</TrafficClass> -->
					<MulticastTimeout>50</MulticastTimeout>
					<DatagramMaximumPacketSize>4096</DatagramMaximumPacketSize>
				</Incoming>
				<Outgoing>
					<ReuseAddress>true</ReuseAddress>
					<ReceiveBufferSize>65000</ReceiveBufferSize>
					<SendBufferSize>65000</SendBufferSize>
					<!-- <MulticastBindToAddress>true</MulticastBindToAddress> -->
					<!-- <MulticastInterfaceAddress>192.168.1.22</MulticastInterfaceAddress> -->
					<!-- <TrafficClass>0</TrafficClass> -->
					<MulticastTimeout>50</MulticastTimeout>
					<DatagramMaximumPacketSize>4096</DatagramMaximumPacketSize>
				</Outgoing>
			</DatagramConfiguration>
			<UnicastIncoming>
				<ProcessorCount>8</ProcessorCount>
			</UnicastIncoming>
			<UnicastOutgoing>
				<ProcessorCount>16</ProcessorCount>
			</UnicastOutgoing>
			<MulticastIncoming>
				<ProcessorCount>8</ProcessorCount>
			</MulticastIncoming>
			<MulticastOutgoing>
				<ProcessorCount>8</ProcessorCount>
			</MulticastOutgoing>
		</RTP>
		<Application>
			<ApplicationTimeout>60000</ApplicationTimeout>
			<PingTimeout>12000</PingTimeout>
			<ValidationFrequency>20000</ValidationFrequency>
			<MaximumPendingWriteBytes>0</MaximumPendingWriteBytes>
			<MaximumSetBufferTime>60000</MaximumSetBufferTime>
		</Application>
		<StartStartupStreams>true</StartStartupStreams>
		<!-- Properties defined here will be added to the IVHost.getProperties() collection -->
		<Properties>
		</Properties>
	</VHost>
</Root>

```

**Error**

```auto
java.lang.OutOfMemoryError: Java heap space
ERROR	server	comment	2013-04-05	03:20:01	-	-	-	-	-	948339.749	-	-	-	-	-	-	-	-	MediaCasterConnection.connect: Failed to connect[67.212.165.162:7408]: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: Connection refused].
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
	at java.nio.HeapByteBuffer.<init>(HeapByteBuffer.java:57)
	at java.nio.ByteBuffer.allocate(ByteBuffer.java:329)
	at org.apache.mina.common.SimpleByteBufferAllocator.allocate(Unknown Source)
	at org.apache.mina.common.ByteBuffer.allocate(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.read(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.process(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.access$600(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor$Worker.run(Unknown Source)
	at org.apache.mina.util.NamePreservingRunnable.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.42	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
	at java.nio.HeapByteBuffer.<init>(HeapByteBuffer.java:57)
	at java.nio.ByteBuffer.allocate(ByteBuffer.java:329)
	at org.apache.mina.common.SimpleByteBufferAllocator.allocate(Unknown Source)
	at org.apache.mina.common.ByteBuffer.allocate(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.read(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.process(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.access$600(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor$Worker.run(Unknown Source)
	at org.apache.mina.util.NamePreservingRunnable.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
	at java.nio.HeapByteBuffer.<init>(HeapByteBuffer.java:57)
	at java.nio.ByteBuffer.allocate(ByteBuffer.java:329)
	at org.apache.mina.common.SimpleByteBufferAllocator.allocate(Unknown Source)
	at org.apache.mina.common.ByteBuffer.allocate(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.read(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.process(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.access$600(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor$Worker.run(Unknown Source)
	at org.apache.mina.util.NamePreservingRunnable.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.414	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.42	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.42	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.42	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.42	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.42	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.414	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.414	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.414	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.414	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.42	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.414	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.414	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.414	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.414	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.42	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	2013-03-25	03:54:23	-	-	-	-	-	1.414	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space
	at java.nio.HeapByteBuffer.<init>(HeapByteBuffer.java:57)
	at java.nio.ByteBuffer.allocate(ByteBuffer.java:329)
	at org.apache.mina.common.SimpleByteBufferAllocator.allocate(Unknown Source)
	at org.apache.mina.common.ByteBuffer.allocate(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.read(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.process(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.access$600(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor$Worker.run(Unknown Source)
	at org.apache.mina.util.NamePreservingRunnable.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
java.lang.OutOfMemoryError: Java heap space

```

---

<div class="post-metadata">

### Author: ![Jason\_Hilton](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/jason_hilton/32/437_2.png) [@Jason\_Hilton](https://community.wowza.com/u/Jason_Hilton)
#### Post date: [April 9, 2013, 11:01am UTC](https://community.wowza.com/t/wowza-failed-after-10-days-java-lang-outofmemoryerror-java-heap-space/33720/2 "2013-04-09T11:01:07Z")

</div>

Hi

How many viewers to you have to the 297 published streams?

It sounds like it’s time to move some of your traffic onto a second server in my opinion.

Wowza doesn’t have any hard limits to publishing or viewers but if you overload the server you’ll get these kinds of issues.

The number of streams that you have inbound are certainly over the number that we recommend which is between 200-250.

Jason

---

<div class="post-metadata">

### Author: ![eduardo\_espinoza\_sua](https://avatars.discourse-cdn.com/v4/letter/e/54ee81/32.png) [@eduardo\_espinoza\_sua](https://community.wowza.com/u/eduardo_espinoza_sua)
#### Post date: [April 9, 2013, 6:08am UTC](https://community.wowza.com/t/wowza-failed-after-10-days-java-lang-outofmemoryerror-java-heap-space/33720/3 "2013-04-09T06:08:19Z")

</div>

Thanks for your reply JasonH

I reduced Inbound streams up to 220 now

I made some tweaks minutes ago to see how is going.

Btw, I received a weird message after stop wowza, minutes ago. /usr/local/WowzaMediaServer/bin/setenv.sh: line 10: -Xmx8000M: command not found

```auto
[root@server ~]# service WowzaMediaServer stop
/usr/local/WowzaMediaServer/bin/setenv.sh: line 10: -Xmx8000M: command not found
WowzaMediaServer: stopping
waiting for processes to exit
waiting for processes to exit
waiting for processes to exit
waiting for processes to exit
waiting for processes to exit
waiting for processes to exit
waiting for processes to exit
waiting for processes to exit
waiting for processes to exit
waiting for processes to exit
waiting for processes to exit
waiting for processes to exit
killing processes which didn't stop after 20 seconds [OK]
[root@server ~]# service WowzaMediaServer start
/usr/local/WowzaMediaServer/bin/setenv.sh: line 10: -Xmx8000M: command not found
WowzaMediaServer: starting [OK]                

```

wowza started sucesfully.

Added this Property to the “Application.xml//”

```auto
Code:
<Property> 
	<Name>reconnectWaitTime</Name> 
	<Value>10000</Value>
</Property>

```

Regards

Ed

---

<div class="post-metadata">

### Author: ![eduardo\_espinoza\_sua](https://avatars.discourse-cdn.com/v4/letter/e/54ee81/32.png) [@eduardo\_espinoza\_sua](https://community.wowza.com/u/eduardo_espinoza_sua)
#### Post date: [April 9, 2013, 9:53am UTC](https://community.wowza.com/t/wowza-failed-after-10-days-java-lang-outofmemoryerror-java-heap-space/33720/4 "2013-04-09T09:53:25Z")

</div>

Thanks JasonH for your reply

Yes, I omited JAVA\_OPTS="$JAVA\_OPTS at sevenv.sh line 10

Corrected now.

Ed

---

<div class="post-metadata">

### Author: ![Jason\_Hilton](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/jason_hilton/32/437_2.png) [@Jason\_Hilton](https://community.wowza.com/u/Jason_Hilton)
#### Post date: [April 9, 2013, 2:30pm UTC](https://community.wowza.com/t/wowza-failed-after-10-days-java-lang-outofmemoryerror-java-heap-space/33720/5 "2013-04-09T14:30:25Z")

</div>

Hi

If your tweak was changing the setenv.sh file then I suggest you change it back as it appears to be incorrect.

Jason

---

<div class="post-metadata">

### Author: ![Jason\_Hilton](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/jason_hilton/32/437_2.png) [@Jason\_Hilton](https://community.wowza.com/u/Jason_Hilton)
#### Post date: [April 10, 2013, 1:30pm UTC](https://community.wowza.com/t/wowza-failed-after-10-days-java-lang-outofmemoryerror-java-heap-space/33720/6 "2013-04-10T13:30:25Z")

</div>

Hi

Glad it’s working now, thanks for the update.

Jason
