# Wirecast -4018 error when initiating broadcast - no error in FMLE

**URL:** <https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520>\
**Category:** Wowza Streaming Engine\
**Created:** [November 6, 2010, 12:56pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520 "2010-11-06T12:56:36Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![system](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/system/32/447_2.png) [@system](https://community.wowza.com/u/system)\
**Post date:** [November 6, 2010, 12:56pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/1 "2010-11-06T12:56:36Z")

</div>

- Adobe FMLE works using same account and credentials. This is an existing working system. Again, FMLE can authenticate with the very same account. Wirecast used to work. We are not sure exactly at what upgrade of Wowza it stopped working (it was sometime in the last couple months).

- Using latest version of wms-plugin-security.jar . Using Wowza server version 2.1.1 . Wirecast 3.5.8 (win). Also removed/installed Wirecast again. All firewalls off.

- Wirecast cannot broadcast if application is configured to use RTMP authentication via module “ModuleRTMPAuthenticate”. The error "Cannot connect to the RTMP/Flash server at the given IP address. Verify the server is reachable at the given address. [-4018]

- Have tried Wirecast and FMLE 3 user agent options in Wirecast

- Can be re-produced from multiple locations . Again FMLE works.

- Application.xml is setup correctly. The following module entry is the last entry in the module list:

> ModuleRTMPAuthenticate
> 
> ModuleRTMPAuthenticate
> 
> com.wowza.wms.plugin.security.ModuleRTMPAuthenticate
> 
> Access log for failed Wirecast connection attempt:
> 
> > 2010-11-06 13:15:32 PDT connect-pending session INFO 100 127.0.0.1 - _defaultVHost_ live _definst_ 0.0030 [any] 1935 rtmp://localhost/live?authmod=adobe&user=live 127.0.0.1 rtmp rtmp://localhost/live?authmod=adobe&user=live FMLE/3.0 (compatible; FMSc/1.0) 499184080 3356 3073 - - - - - - - - - - - - - rtmp://localhost/live authmod=adobe&user=live
> > 
> > 2010-11-06 13:15:32 PDT connect session INFO 401 127.0.0.1 - _defaultVHost_ live _definst_ 0.0040 [any] 1935 rtmp://localhost/live?authmod=adobe&user=live 127.0.0.1 rtmp rtmp://localhost/live?authmod=adobe&user=live FMLE/3.0 (compatible; FMSc/1.0) 499184080 3356 3073 - - - - - - - - - - - - - rtmp://localhost/live authmod=adobe&user=live
> > 
> > 2010-11-06 13:15:32 PDT disconnect session INFO 200 499184080 - _defaultVHost_ live _definst_ 0.0060 [any] 1935 rtmp://localhost/live?authmod=adobe&user=live 127.0.0.1 rtmp rtmp://localhost/live?authmod=adobe&user=live FMLE/3.0 (compatible; FMSc/1.0) 499184080 3372 3422 - - - - - - - - - - - - - rtmp://localhost/live authmod=adobe&user=live
> > 
> > Access log entries when FMLE connects (working) :
> > 
> > > 2010-11-06 13:15:33 PDT connect-pending session INFO 100 127.0.0.1 - _defaultVHost_ live _definst_ 0.0030 [any] 1935 rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== 127.0.0.1 rtmp rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== FMLE/3.0 (compatible; FMSc/1.0) 1721949869 3564 3073 - - - - - - - - - - - - - rtmp://localhost/live authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ==
> > > 
> > > 2010-11-06 13:15:33 PDT connect session INFO 200 127.0.0.1 - _defaultVHost_ live _definst_ 0.0060 [any] 1935 rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== 127.0.0.1 rtmp rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== FMLE/3.0 (compatible; FMSc/1.0) 1721949869 3564 3073 - - - - - - - - - - - - - rtmp://localhost/live authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ==
> > > 
> > > 2010-11-06 13:15:34 PDT create stream INFO 200 - - _defaultVHost_ live _definst_ 0.011 [any] 1935 rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== 127.0.0.1 rtmp rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== FMLE/3.0 (compatible; FMSc/1.0) 1721949869 3715 3411 1 0 0 0 - - - - - - rtmp://localhost/live rtmp://localhost/live - rtmp://localhost/live authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ==
> > > 
> > > 2010-11-06 13:15:34 PDT publish stream INFO 200 broadcast1 - _defaultVHost_ live _definst_ 0.014 [any] 1935 rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== 127.0.0.1 rtmp rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== FMLE/3.0 (compatible; FMSc/1.0) 1721949869 3810 3452 1 0 0 0 broadcast1 videoKeyframeFrequency=5&totalDatarate=128 - - - - rtmp://localhost/live/broadcast1?videoKeyframeFrequency=5&totalDatarate=128 rtmp://localhost/live/broadcast1 videoKeyframeFrequency=5&totalDatarate=128 rtmp://localhost/live authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ==
> > > 
> > > 2010-11-06 13:15:35 PDT comment server INFO 200 - LiveStreamPacketizerCupertino.init[live/_definst_/broadcast1]: chunkDurationTarget: 10000 - - - 246.828 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:35 PDT comment server INFO 200 - LiveStreamPacketizerCupertino.init[live/_definst_/broadcast1]: chunkDurationTolerance: 500 - - - 246.829 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:35 PDT comment server INFO 200 - LiveStreamPacketizerCupertino.init[live/_definst_/broadcast1]: audioGroupCount: 3 - - - 246.829 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:35 PDT comment server INFO 200 - LiveStreamPacketizerCupertino.init[live/_definst_/broadcast1]: playlistChunkCount:3 - - - 246.829 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:35 PDT comment server INFO 200 - MediaStreamMap.getLiveStreamPacketizer: Create live stream packetizer: cupertinostreamingpacketizer:broadcast1 - - - 246.83 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:35 PDT comment server INFO 200 - CupertinoPacketHandler.startStream[live/_definst_/broadcast1] - - - 246.831 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:35 PDT comment server INFO 200 - LiveStreamPacketizerCupertino.handlePacket: Video codec: H264 - - - 246.832 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:35 PDT comment server INFO 200 - LiveStreamPacketizerCupertino.handlePacket: Video info[live/_definst_/broadcast1]: {H264CodecConfigInfo: profile: “Baseline”, level: 3.0, frameSize: 320x240, aspect: 1/1} - - - 246.835 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:35 PDT comment server INFO 200 - MediaStreamMap.getLiveStreamPacketizer: Create live stream packetizer: smoothstreamingpacketizer:broadcast1 - - - 246.838 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:35 PDT comment server INFO 200 - LiveStreamPacketizerSmoothStreaming.startStream[live/_definst_/broadcast1] - - - 246.839 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:35 PDT comment server INFO 200 - LiveStreamPacketizerCupertino.handlePacket: Audio codec: MP3 - - - 246.959 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:40 PDT comment server INFO 200 - LiveStreamPacketizerSmoothStreaming.flushPendingAudio: Bitrate[live/_definst_/broadcast1]: 47737 - - - 252.312 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:43 PDT unpublish stream INFO 200 broadcast1 - _defaultVHost_ live _definst_ 8.728 [any] 1935 rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== 127.0.0.1 rtmp rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== FMLE/3.0 (compatible; FMSc/1.0) 1721949869 88459 3612 1 0 84858 0 broadcast1 videoKeyframeFrequency=5&totalDatarate=128 - - - - rtmp://localhost/live/broadcast1?videoKeyframeFrequency=5&totalDatarate=128 rtmp://localhost/live/broadcast1 videoKeyframeFrequency=5&totalDatarate=128 rtmp://localhost/live authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ==
> > > 
> > > 2010-11-06 13:15:43 PDT destroy stream INFO 200 broadcast1 - _defaultVHost_ live _definst_ 8.73 [any] 1935 rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== 127.0.0.1 rtmp rtmp://localhost/live?authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ== FMLE/3.0 (compatible; FMSc/1.0) 1721949869 88505 3762 1 0 84858 0 broadcast1 videoKeyframeFrequency=5&totalDatarate=128 - - - - rtmp://localhost/live/broadcast1?videoKeyframeFrequency=5&totalDatarate=128 rtmp://localhost/live/broadcast1 videoKeyframeFrequency=5&totalDatarate=128 rtmp://localhost/live authmod=adobe&user=live&challenge=iAQAAA==&response=O9PDgpVdubKZjjrnNC3+pw==&opaque=6wm0uQ==
> > > 
> > > 2010-11-06 13:15:55 PDT comment server INFO 200 - MediaStreamMap.removeLiveStreamPacketizer[live/_definst_/broadcast1]: Destroy live stream packetizer: cupertinostreamingpacketizer - - - 266.473 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > 2010-11-06 13:15:55 PDT comment server INFO 200 - MediaStreamMap.removeLiveStreamPacketizer[live/_definst_/broadcast1]: Destroy live stream packetizer: smoothstreamingpacketizer - - - 266.473 - - - - - - - - - - - - - - - - - - - - - - - - -
> > > 
> > > We need to get Wirecast RTMP authentication working again. What can possibly be wrong?

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [November 6, 2010, 10:52pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/2 "2010-11-06T22:52:11Z")

</div>

Try re-downloading the MediaSecurity Addon

[https://www.wowza.com/docs/media-security-overview](https://www.wowza.com/docs/media-security-overview)

Copy /lib/wms-plugin-security.jar file over the one in Wowza /lib folder, then restart Wowza.

Richard

---

<div class="post-metadata">

**Author:** ![Hans\_Ketelbueters](https://avatars.discourse-cdn.com/v4/letter/h/d78d45/32.png) [@Hans\_Ketelbueters](https://community.wowza.com/u/Hans_Ketelbueters)\
**Post date:** [January 12, 2011, 9:58pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/3 "2011-01-12T21:58:25Z")

</div>

Bumped into the same problem:

[http://forum.telestream.net/forum/messageview.aspx?catid=45&threadid=6939&STARTPAGE=1](http://forum.telestream.net/forum/messageview.aspx?catid=45&threadid=6939&STARTPAGE=1)

Any updates on this?

---

<div class="post-metadata">

**Author:** ![Hans\_Ketelbueters](https://avatars.discourse-cdn.com/v4/letter/h/d78d45/32.png) [@Hans\_Ketelbueters](https://community.wowza.com/u/Hans_Ketelbueters)\
**Post date:** [January 12, 2011, 11:35pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/4 "2011-01-12T23:35:54Z")

</div>

> In my test I was able to get 4018 error by “trying to connect to Wowza when it is not running, or by trying to connect to an application that does not exist.”

Ok, I suppose that would be normal behaviour.

I get this error randomly with a valid address/application when hitting the broadcast button.

Could you try to start/stop broadcast several times to an application that requires authentication?

In my case this just randomly succeeds/fails without changing any settings.

> The debug logs from Wowza in the Wirecast forum post do not indicate any problems. btw, debug logs have too much info for most situations, and actually make it more difficult to figure out what is happening. In a few cases they are necessary.
> 
> I understand, but in this case it might be useful, as the INFO logs almost outputs anything.
> 
> A failed session starts with
> 
> DEBUG server comment - queryStr: authmod=adobe&user=a
> 
> While a successfull session:
> 
> DEBUG server comment - queryStr: authmod=adobe&user=a&challenge=dGcAAA==&response=KJ5m5CIJKQxPZwqM25u7qg==&opaque=MWBqvA==
> 
> (cfr. [http://forum.telestream.net/forum/messageview.aspx?catid=45&threadid=6939&STARTPAGE=1](http://forum.telestream.net/forum/messageview.aspx?catid=45&threadid=6939&STARTPAGE=1) )

---

<div class="post-metadata">

**Author:** ![Hans\_Ketelbueters](https://avatars.discourse-cdn.com/v4/letter/h/d78d45/32.png) [@Hans\_Ketelbueters](https://community.wowza.com/u/Hans_Ketelbueters)\
**Post date:** [January 12, 2011, 11:52pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/5 "2011-01-12T23:52:16Z")

</div>

> Sounds like you are stress testing Wirecast and Wowza. If you are getting this error when you “start/stop broadcast several times to an application that requires authentication”, then don’t do that.
> 
> Richard

Not stress testing, just normal use. I just noticed it was random because sometimes it is not working the first time.

When you have multiple (bitrate) streams configured in the broadcast settings, the problem gets more anoying, because both can fail.

Sometimes we need to stop/start up to 5 times until both streams are published.

---

<div class="post-metadata">

**Author:** ![Hans\_Ketelbueters](https://avatars.discourse-cdn.com/v4/letter/h/d78d45/32.png) [@Hans\_Ketelbueters](https://community.wowza.com/u/Hans_Ketelbueters)\
**Post date:** [January 13, 2011, 12:12am UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/6 "2011-01-13T00:12:36Z")

</div>

I don’t know whether Wirecast or Wowza is causing the problem. Posted it first in Wirecast forum, and they suggested to contact Wowza as well, as you can read in the Wirecast forum.

I see a clear difference between the successful and failed logs, but you might know better how to interpret this:

DEBUG server comment - queryStr: authmod=adobe&user=a

vs

DEBUG server comment - queryStr: authmod=adobe&user=a&challenge=dGcAAA==&response=KJ5m5CIJKQxPZwqM25u7qg==&opaque=MWBqvA==

To replicate it:

Clean Wowza 2.2.3 install, and added 2 security (2.0) jars in the lib folder

Create a “live” application with ModuleRTMPAuthenticate module, and insert a user-pwd in publish.password

Use Wirecast 4.0.1 with these credentials set, and try to stop/start broadcast a few times

---

<div class="post-metadata">

**Author:** ![Hans\_Ketelbueters](https://avatars.discourse-cdn.com/v4/letter/h/d78d45/32.png) [@Hans\_Ketelbueters](https://community.wowza.com/u/Hans_Ketelbueters)\
**Post date:** [January 13, 2011, 12:23am UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/7 "2011-01-13T00:23:26Z")

</div>

MediaSecurity\_2.0.zip contains:

wms-plugin-security.jar

wms-plugin-security-encryption.jar

---

<div class="post-metadata">

**Author:** ![Hans\_Ketelbueters](https://avatars.discourse-cdn.com/v4/letter/h/d78d45/32.png) [@Hans\_Ketelbueters](https://community.wowza.com/u/Hans_Ketelbueters)\
**Post date:** [March 2, 2011, 11:09pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/8 "2011-03-02T23:09:33Z")

</div>

We are still experiencing the same problem as well.

Makes no difference where you enter the credentials.

A difference with dptekco : sometimes the authentication does succeed. (all described in posts above)

side note: I have the impression the success rate depends on location of the broadcaster (latency?). Today we had to turn the auth. off because the broadcaster needed that many attempts it with would be to much of a risk to use (what if broadcaster needed a restart during the event).

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [November 9, 2010, 12:25am UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/9 "2010-11-09T00:25:53Z")

</div>

In the Wirecast Broadcast Settings dialog, click button labeled “Set Credentials…”. Add username and password here. Click OK, then save. Then you can publish from Wirecast with ModuleRTMPAuthenticate.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [November 9, 2010, 1:58pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/10 "2010-11-09T13:58:09Z")

</div>

I am able to generate a 4018 error code in Wirecast by trying to connect to Wowza when it is not running, or by trying to connect to an application that does not exist.

Can you zip up conf, logs and screen shots of Wirecast settings and send to support@wowza.com

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [January 12, 2011, 11:08pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/11 "2011-01-12T23:08:03Z")

</div>

In my test I was able to get 4018 error by “trying to connect to Wowza when it is not running, or by trying to connect to an application that does not exist.”

The debug logs from Wowza in the Wirecast forum post do not indicate any problems. btw, debug logs have too much info for most situations, and actually make it more difficult to figure out what is happening. In a few cases they are necessary.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [January 12, 2011, 11:42pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/12 "2011-01-12T23:42:01Z")

</div>

Sounds like you are stress testing Wirecast and Wowza. If you are getting this error when you “start/stop broadcast several times to an application that requires authentication”, then don’t do that.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [January 12, 2011, 11:58pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/13 "2011-01-12T23:58:31Z")

</div>

I’m not sure. I don’t see a problem in the logs you posted in the Wirecast forum. The error is coming from an encoder, not Wowza. If you can find a definitive correlation in the Wowza logs and can tell us how to replicate it, we can look at it.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [January 13, 2011, 12:20am UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/14 "2011-01-13T00:20:57Z")

</div>

Two security jars? I know of one.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [March 2, 2011, 5:33pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/15 "2011-03-02T17:33:02Z")

</div>

I could never replicate a problem. If you are expecting a login dialog to pop-up like FMLE, you don’t get that.

Open Broadcast Settings dialog and click Set Credentials button to enter username and password

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [March 2, 2011, 6:08pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/16 "2011-03-02T18:08:00Z")

</div>

I tried it again and setting username and password that way didn’t work. However when I published and got a fail message, there was a button labeled “edit”, which I clicked and it opened the same credentials dialog. I set my username and password there, and it worked. So it is more like FMLE actually.

This is Wirecast 4.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [March 2, 2011, 9:54pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/17 "2011-03-02T21:54:08Z")

</div>

Zip up and send the conf _and_ logs folders to support@wowza.com

Do a few tests first to generate logging

Tell us which application is configured for security and that you have been testing.

Include a link that I can try to publish to with Wirecast.

Include a link to this thread.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [March 3, 2011, 3:45pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/18 "2011-03-03T15:45:48Z")

</div>

One thought, does /conf/publish.password file have non-text word processor formatting?

@bubbles01, can you send support@wowza.com a rtmp url to secured Wowza application, along with username and password, so I can try to connect and play from Wirecast and FMLE.

And do a couple of tests and zip up conf _and_ logs folders and send those. It would help a lot if you started with a empty access log, and just had testing related logging in the file you send.

Tell us what version of Wirecast and Wowza you are using.

Please include a link to this thread.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [March 4, 2011, 4:47pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/19 "2011-03-04T16:47:21Z")

</div>

Try changing User Agent to “FMLE/3.0” in the Broadcast settings dialog. That worked for me.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [May 3, 2012, 9:49pm UTC](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520/20 "2012-05-03T21:49:49Z")

</div>

Do you have ModuleRTMPAuthenticate setup on the application you are publishing to? Wirecast does not popup box for username/password, you have to open Set Credentials dialog to enter.

Richard

[Next page](https://community.wowza.com/t/wirecast-4018-error-when-initiating-broadcast-no-error-in-fmle/520.md?page=2)
