# URGENT : Load Balancing 4.0 : ERROR using redirect path...

**URL:** https://community.wowza.com/t/urgent-load-balancing-4-0-error-using-redirect-path/43789
**Category:** Wowza Streaming Engine
**Tags:** server-administration
**Created:** [April 15, 2015, 11:07am UTC](https://community.wowza.com/t/urgent-load-balancing-4-0-error-using-redirect-path/43789 "2015-04-15T11:07:04Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Michel\_CAPEL](https://avatars.discourse-cdn.com/v4/letter/m/e8c25b/32.png) [@Michel\_CAPEL](https://community.wowza.com/u/Michel_CAPEL)
#### Post date: [April 15, 2015, 11:07am UTC](https://community.wowza.com/t/urgent-load-balancing-4-0-error-using-redirect-path/43789/1 "2015-04-15T11:07:04Z")

</div>

Hello everyone,

I have a Wowza server well running, with a live stream (origin), but limited to 100 viewers.

So now I decided to have another server to have more viewers.

I successfully added a new Wowza server with edge mode and can play my stream using one of the following URLs :

- rtmp://tv.mondeduloisir.fr/tixtv/web (ORIGIN, IP = 94.23.194.145, Wowza version = 4.1.1)

- rtmp://edge001.tv.mondeduloisir.fr/tixtv/web (EDGE, IP = 37.187.149.82, Wowza version = 4.1.2)

It’s the same stream and the same timecode as expected ! 🙂

But I needed a Load Balancing option to choose the best server from only one URL.

So I followed that URL : [https://www.wowza.com/docs/how-to-get-dynamic-load-balancing-addon](https://www.wowza.com/docs/how-to-get-dynamic-load-balancing-addon) for 4.0 version.

To test it, I’m using that URL : rtmp://tv.mondeduloisir.fr/redirect/tixtv/web (note “redirect” term).

But I have that error in the access logs :

```auto
2015-04-15	11:05:31	CEST	connect	session	INFO	200	78.220.200.72	-	_defaultVHost_	redirect	tixtv	0.121	[any]	1935	rtmp://tv.mondeduloisir.fr/redirect/tixtv/	78.220.200.72	rtmp	http://p.jwpcdn.com/6/12/jwplayer.flash.swf	WIN 17,0,0,134	952965818	3433	3073	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://tv.mondeduloisir.fr/redirect/tixtv/	-
2015-04-15	11:05:31	CEST	create	stream	INFO	200	-	-	_defaultVHost_	redirect	tixtv	0.025	[any]	1935	rtmp://tv.mondeduloisir.fr/redirect/tixtv/	78.220.200.72	rtmp	http://p.jwpcdn.com/6/12/jwplayer.flash.swf	WIN 17,0,0,134	952965818	3486	3413	1	-	0	0	-	-	-	-	0	0.0	rtmp://tv.mondeduloisir.fr/redirect/tixtv/	rtmp://tv.mondeduloisir.fr/redirect/tixtv/	-	rtmp://tv.mondeduloisir.fr/redirect/tixtv/	-
2015-04-15	11:05:31	CEST	comment	server	WARN	200	-	MediaReaderH264.open[redirect/tixtv]: Not found: D:/Wowza/content/web.: java.io.FileNotFoundException: D:\Wowza\content\web (Le fichier spécifié est introuvable)|at java.io.RandomAccessFile.open(Native Method)|at java.io.RandomAccessFile.<init>(RandomAccessFile.java:243)|at com.wowza.io.WowzaRandomAccessFile.<init>(WowzaRandomAccessFile.java:12)|at com.wowza.io.DirectRandomAccessReader.open(DirectRandomAccessReader.java:222)|at com.wowza.wms.mediareader.h264.MediaReaderH264.open(MediaReaderH264.java:250)|	-	-	-	110.161	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
2015-04-15	11:05:31	CEST	destroy	stream	INFO	200	web	-	_defaultVHost_	redirect	tixtv	0.448	[any]	1935	rtmp://tv.mondeduloisir.fr/redirect/tixtv/	78.220.200.72	rtmp	http://p.jwpcdn.com/6/12/jwplayer.flash.swf	WIN 17,0,0,134	952965818	3550	3643	1	-	0	0	web	-	-	-	-	-	rtmp://tv.mondeduloisir.fr/redirect/tixtv//web	rtmp://tv.mondeduloisir.fr/redirect/tixtv//web	-	rtmp://tv.mondeduloisir.fr/redirect/tixtv/	-
2015-04-15	11:05:31	CEST	disconnect	session	INFO	200	952965818	-	_defaultVHost_	redirect	tixtv	0.644	[any]	1935	rtmp://tv.mondeduloisir.fr/redirect/tixtv/	78.220.200.72	rtmp	http://p.jwpcdn.com/6/12/jwplayer.flash.swf	WIN 17,0,0,134	952965818	3550	3643	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://tv.mondeduloisir.fr/redirect/tixtv/	-

```

And that error in error logs :

```auto
WARN	server	comment	2015-04-15	11:05:31	-	-	-	-	-	110.161	-	-	-	-	-	-	-	-	MediaReaderH264.open[redirect/tixtv]: Not found: D:/Wowza/content/web.: java.io.FileNotFoundException: D:\Wowza\content\web (Le fichier spécifié est introuvable)|at java.io.RandomAccessFile.open(Native Method)|at java.io.RandomAccessFile.<init>(RandomAccessFile.java:243)|at com.wowza.io.WowzaRandomAccessFile.<init>(WowzaRandomAccessFile.java:12)|at com.wowza.io.DirectRandomAccessReader.open(DirectRandomAccessReader.java:222)|at com.wowza.wms.mediareader.h264.MediaReaderH264.open(MediaReaderH264.java:250)|

```

Why ???

For your information, the MASTER storageDir is : D:/Wowza\_Content (I’m using Windows Server 2012).

Why I have “java.io.FileNotFoundException: D:\Wowza\content\web” (not the same folder…) ???

What I missed ? It’s really urgent of course… 🙂

Best regards.

---

<div class="post-metadata">

### Author: ![Zoran](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/zoran/32/385_2.png) [@Zoran](https://community.wowza.com/u/Zoran)
#### Post date: [April 15, 2015, 12:38pm UTC](https://community.wowza.com/t/urgent-load-balancing-4-0-error-using-redirect-path/43789/2 "2015-04-15T12:38:51Z")

</div>

Hi,

Did you correctly create the “redirect” application on your origin server? This is described in the WowzaDynamicLoadBalancingAddOn\_UsersGuide.pdf document on page 13 in the “RTMP redirection” section.

Zoran

---

<div class="post-metadata">

### Author: ![Zoran](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/zoran/32/385_2.png) [@Zoran](https://community.wowza.com/u/Zoran)
#### Post date: [April 16, 2015, 11:07am UTC](https://community.wowza.com/t/urgent-load-balancing-4-0-error-using-redirect-path/43789/3 "2015-04-16T11:07:17Z")

</div>

Hi,

Can you open a support ticket by sending an email to support@wowza.com with a detailed description of the problem and also a reference to this forum post.

Also, make sure to attach an archive containing the contents of your Wowza conf/ and logs/ folders so we could take a closer look at your setup.

Zoran

---

<div class="post-metadata">

### Author: ![Michel\_CAPEL](https://avatars.discourse-cdn.com/v4/letter/m/e8c25b/32.png) [@Michel\_CAPEL](https://community.wowza.com/u/Michel_CAPEL)
#### Post date: [April 15, 2015, 2:48pm UTC](https://community.wowza.com/t/urgent-load-balancing-4-0-error-using-redirect-path/43789/4 "2015-04-15T14:48:35Z")

</div>

> Hi,
> 
> Did you correctly create the “redirect” application on your origin server? This is described in the WowzaDynamicLoadBalancingAddOn\_UsersGuide.pdf document on page 13 in the “RTMP redirection” section.
> 
> Zoran

Hello,

Thanks for reply.

Yes I did it, but missing Application.xml in conf folder. Added it but something else happen in access logs :

```auto
2015-04-15	15:44:01	CEST	comment	server	INFO	200	-	MediaCasterStreamValidator.init[redirect/tixtv]: Started	-	-	-	135.422	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
2015-04-15	15:44:01	CEST	comment	server	INFO	200	-	ModuleCoreSecurity.onAppStart[redirect/tixtv]: Publish: AllowedEncoders: securityPublishValidEncoders:Wirecast/|FME/|FMLE/|Wowza GoCoder*	-	-	-	135.431	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
2015-04-15	15:44:01	CEST	comment	server	INFO	200	-	ModuleCoreSecurity.onAppStart[redirect/tixtv]: Publish: block duplicate stream names : false	-	-	-	135.432	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
2015-04-15	15:44:01	CEST	comment	server	INFO	200	-	ModuleCoreSecurity.onAppStart[redirect/tixtv]: Play: Max Connections: securityPlayMaximumConnections:300	-	-	-	135.433	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
2015-04-15	15:44:01	CEST	comment	server	INFO	200	-	ModuleCoreSecurity.onAppStart[redirect/tixtv]: Play: SecureConnection: securityPlayRequireSecureConnection:false	-	-	-	135.434	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
2015-04-15	15:44:01	CEST	comment	server	INFO	200	-	ModuleCoreSecurity.onAppStart[redirect/tixtv]: Play: securitySecureTokenVersion property is missing, using SecureToken Version 1, play security enabled for RTMP only	-	-	-	135.435	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
2015-04-15	15:44:01	CEST	app-start	application	INFO	200	tixtv	redirect/tixtv	-	-	-	135.444	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
2015-04-15	15:44:01	CEST	connect-pending	session	INFO	100	78.220.200.72	-	_defaultVHost_	redirect	tixtv	0.138	[any]	1935	rtmp://tv.mondeduloisir.fr:1935/redirect/tixtv	78.220.200.72	rtmp	-	LNX 9,0,124,2	1609679011	3312	3073	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://tv.mondeduloisir.fr:1935/redirect/tixtv	-
2015-04-15	15:44:01	CEST	connect	session	INFO	302	78.220.200.72	-	_defaultVHost_	redirect	tixtv	0.139	[any]	1935	rtmp://tv.mondeduloisir.fr:1935/redirect/tixtv	78.220.200.72	rtmp	-	LNX 9,0,124,2	1609679011	3312	3073	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://tv.mondeduloisir.fr:1935/redirect/tixtv	-
2015-04-15	15:44:01	CEST	disconnect	session	INFO	200	1609679011	-	_defaultVHost_	redirect	tixtv	0.176	[any]	1935	rtmp://tv.mondeduloisir.fr:1935/redirect/tixtv	78.220.200.72	rtmp	-	LNX 9,0,124,2	1609679011	3312	3412	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://tv.mondeduloisir.fr:1935/redirect/tixtv	-
2015-04-15	15:45:01	CEST	stop	stream	INFO	200	web	-	_defaultVHost_	tixtv	_definst_	99.634	[any]	1935	rtmp://tv.mondeduloisir.fr:1935/tixtv/_definst_	37.187.149.82	wowz	WowzaProLiveRepeater	WIN 10,0,12,36	22707083	4725	5921838	1	189589	0	5866421	web	-	-	-	-	-	rtmp://tv.mondeduloisir.fr:1935/tixtv/_definst_/web	rtmp://tv.mondeduloisir.fr:1935/tixtv/_definst_/web	-	rtmp://tv.mondeduloisir.fr:1935/tixtv/_definst_	-
2015-04-15	15:45:01	CEST	destroy	stream	INFO	200	web	-	_defaultVHost_	tixtv	_definst_	99.635	[any]	1935	rtmp://tv.mondeduloisir.fr:1935/tixtv/_definst_	37.187.149.82	wowz	WowzaProLiveRepeater	WIN 10,0,12,36	22707083	4725	5921838	1	-	0	5866421	web	-	-	-	-	-	rtmp://tv.mondeduloisir.fr:1935/tixtv/_definst_/web	rtmp://tv.mondeduloisir.fr:1935/tixtv/_definst_/web	-	rtmp://tv.mondeduloisir.fr:1935/tixtv/_definst_	-
2015-04-15	15:45:01	CEST	disconnect	session	INFO	200	22707083	-	_defaultVHost_	tixtv	_definst_	99.687	[any]	1935	rtmp://tv.mondeduloisir.fr:1935/tixtv/_definst_	37.187.149.82	wowz	WowzaProLiveRepeater	WIN 10,0,12,36	22707083	4725	5921838	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://tv.mondeduloisir.fr:1935/tixtv/_definst_	-
2015-04-15	15:45:01	CEST	comment	server	INFO	200	-	onDisconnect: 22707083	_defaultVHost_	tixtv	_definst_	195.354	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
2015-04-15	15:45:02	CEST	app-stop	application	INFO	200	tixtv	redirect/tixtv	-	-	-	195.966	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-

```

It still not working…

Thanks in advance !

---

<div class="post-metadata">

### Author: ![Michel\_CAPEL](https://avatars.discourse-cdn.com/v4/letter/m/e8c25b/32.png) [@Michel\_CAPEL](https://community.wowza.com/u/Michel_CAPEL)
#### Post date: [April 17, 2015, 10:19am UTC](https://community.wowza.com/t/urgent-load-balancing-4-0-error-using-redirect-path/43789/5 "2015-04-17T10:19:18Z")

</div>

Hello,

Thanks for reply.

Finally, the last logs I wrote were not errors, the stream was not played because of my player which do not take into account RTMP redirection… SO IT’S WORKING ! I did some tests with JWPlayer demo website and it’s good.

Topic solved !

Best regards.

---

<div class="post-metadata">

### Author: ![Lee\_Ngeap](https://avatars.discourse-cdn.com/v4/letter/l/71c47a/32.png) [@Lee\_Ngeap](https://community.wowza.com/u/Lee_Ngeap)
#### Post date: [September 24, 2020, 9:09am UTC](https://community.wowza.com/t/urgent-load-balancing-4-0-error-using-redirect-path/43789/6 "2020-09-24T09:09:47Z")

</div>

Hi @Michel_CAPEL;

I’m having the same issue;

Can you please test my redirect rtmp if it’s working?

rtmp://139.59.243.200:1935/redirect/live/test2

I’ve been spending weeks to confirgure the redirct rtmp, but no luck with VLC player. I’m not a developer, so i can run the JW palyer. Can you please provide me the link if you can’t test my stream?

Thanks.
