# Unable to publish or view WebRTC stream on AWS EC2 Linux BYOL

**URL:** https://community.wowza.com/t/unable-to-publish-or-view-webrtc-stream-on-aws-ec2-linux-byol/93673
**Category:** Wowza Streaming Engine
**Tags:** webrtc
**Created:** [August 10, 2021, 12:17am UTC](https://community.wowza.com/t/unable-to-publish-or-view-webrtc-stream-on-aws-ec2-linux-byol/93673 "2021-08-10T00:17:48Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Jeffrey\_Yin](https://avatars.discourse-cdn.com/v4/letter/j/91b2a8/32.png) [@Jeffrey\_Yin](https://community.wowza.com/u/Jeffrey_Yin)
#### Post date: [August 10, 2021, 12:17am UTC](https://community.wowza.com/t/unable-to-publish-or-view-webrtc-stream-on-aws-ec2-linux-byol/93673/1 "2021-08-10T00:17:48Z")

</div>

I am attempting to setup a RTMP -\> WebRTC transcoder [as per this guide](https://www.wowza.com/blog/converting-rtmp-to-webrtc-with-wowza-streaming-engine). I’m using the Wowza Streaming Engine (Linyx BYOL) instance with the default server configuration.

However, when I attempt to publish a test WebRTC stream, I get a error notification ‘Publish failed. Unable to connect.’ From the logs, I see the following warning:

```
Bind failed, try again ([any]:443): java.net.BindException: Address already in use
x-ctx:_defaultVHost_,x-duration:5480.872

```

I moved forward with the tutorial, and was able to push an RTMP feed and view the playback with HLS. However, when I try and playback with WebRTC, I get the following error:

```
WebSocket connection to 'wss://<hostname>.streamlock.net/webrtc-session.json' failed: 
wsConnect @ WowzaPeerConnectionPlay.js:111

```

Do you have any insights on what might be breaking?

---

<div class="post-metadata">

### Author: ![Jeffrey\_Yin](https://avatars.discourse-cdn.com/v4/letter/j/91b2a8/32.png) [@Jeffrey\_Yin](https://community.wowza.com/u/Jeffrey_Yin)
#### Post date: [August 10, 2021, 1:07pm UTC](https://community.wowza.com/t/unable-to-publish-or-view-webrtc-stream-on-aws-ec2-linux-byol/93673/2 "2021-08-10T13:07:53Z")

</div>

Looking into it further, it seems like one possible reason port 443 isn’t working might be that my SSL configuration is incorrect. I have the streamlock certificate, and have it saved to:

> /usr/local/WowzaStreamingEngine/conf/

In the `Virtual Host Setup` section, I have the keystore path setup as:

> ${com.wowza.wms.context.VHostConfigHome}/conf/.streamlock.net.jks

However, I remain unable to access the Engine Manager or the HLS stream using https.

---

<div class="post-metadata">

### Author: ![Jeffrey\_Yin](https://avatars.discourse-cdn.com/v4/letter/j/91b2a8/32.png) [@Jeffrey\_Yin](https://community.wowza.com/u/Jeffrey_Yin)
#### Post date: [August 11, 2021, 3:00pm UTC](https://community.wowza.com/t/unable-to-publish-or-view-webrtc-stream-on-aws-ec2-linux-byol/93673/4 "2021-08-11T15:00:10Z")

</div>

I’m still having this issue with WebRTC streaming, and am possibly having related issues with LL-HLS. I tried following [this guide for LL-HLS](https://www.facebook.com/wowza/videos/375369516942785/)

New [AWS linux ec2 instance](https://aws.amazon.com/marketplace/pp/prodview-ue4m6r2qxtjmm), new license key, new streamlock file. Streamlock keystore file was uploaded to the ec2 instance, and moved to the `WowzaStreamingEngine/conf` directory  
I get to the point where I can push RTMP, and playback with HLS over insecure HTTP. However, I am unable to playback the LL-HLS url using theoplayer and the streamlock url:

> https://\<hostname\>.streamlock.net/live/\<applicationame\>/playlist.m3u8

Am I missing any steps in the setup process? Is the preconfigured Wowza Streaming Engine (Linux BYOL) still recommended? Are there additional steps that need to be performed for EC2?

---

<div class="post-metadata">

### Author: ![Tim\_Dougherty](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/tim_dougherty/32/596_2.png) [@Tim\_Dougherty](https://community.wowza.com/u/Tim_Dougherty)
#### Post date: [August 18, 2021, 8:50pm UTC](https://community.wowza.com/t/unable-to-publish-or-view-webrtc-stream-on-aws-ec2-linux-byol/93673/5 "2021-08-18T20:50:04Z")

</div>

The “Bind failed” error indicates that another application/service is using port 443, on your server. Fix the port conflict at the OS level (decide which service uses which port). You may also change Wowza Streaming Engine from port 443 to any other port (i.e. 8443) by modifying VHost.xml or in Wowza Streaming Engine Manager via the Server \> VHost Configuration pages.
