# Ugh! Bind failed, try again

**URL:** https://community.wowza.com/t/ugh-bind-failed-try-again/37234
**Category:** Wowza Streaming Engine
**Created:** [February 10, 2012, 3:30pm UTC](https://community.wowza.com/t/ugh-bind-failed-try-again/37234 "2012-02-10T15:30:41Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Leopold\_O\_Donnell](https://avatars.discourse-cdn.com/v4/letter/l/c4cdca/32.png) [@Leopold\_O\_Donnell](https://community.wowza.com/u/Leopold_O_Donnell)
#### Post date: [February 10, 2012, 3:30pm UTC](https://community.wowza.com/t/ugh-bind-failed-try-again/37234/1 "2012-02-10T15:30:41Z")

</div>

OK - I’ve been around long enough to have checked the obvious - but can’t for the life of me understand why the dang server won’t start.

I’m a monthly subscriber with a CENTOS instance on AWS that I’m currently developing with. Wowza 3 had been working fine a month back, but now I’m ready to get going on it again and I’m getting:

```auto
2012-02-10	15:13:37	EST	comment	vhost	WARN	200	_defaultVHost_	Bind failed, try again ([any]:1935): java.net.BindException: Address already in use	-	-	-	43.79

```

Netstat -a |fgrep 1935 produces

```auto
tcp 0 0 localhost:19350 *:* LISTEN      
tcp 0 0 localhost:37118 localhost:19350 ESTABLISHED 
tcp 0 0 localhost:19350 localhost:37118 ESTABLISHED 
udp 0 0 ip-10-111-31-17.e:19350 *:*                                     
udp 0 0 localhost:19350 *:*                                     
udp 0 0 ip-10-111-31-17.e:19351 *:*                                     
udp 0 0 localhost:19351 *:*  

```

I’ve rebooted - with no success

I"ve got ports open through my Security Group

I’ve grabbed the latest WowzaMediaServer-3.0.x-3.0.4

No Joy!

Any Ideas? Anyone?

---

<div class="post-metadata">

### Author: ![Randall\_Auriemma](https://avatars.discourse-cdn.com/v4/letter/r/85e7bf/32.png) [@Randall\_Auriemma](https://community.wowza.com/u/Randall_Auriemma)
#### Post date: [February 10, 2012, 9:06pm UTC](https://community.wowza.com/t/ugh-bind-failed-try-again/37234/2 "2012-02-10T21:06:29Z")

</div>

In Linux, it’s “netstat -p” to see the program associated with the port. You’ll have to figure out what that program is and stop it, change its port, or change Wowza’s port.

Check that you don’t have the Wowza service already loaded. Do “ps aux |grep java”. Look in the Wowza User Guide for info on how to start/stop the Wowza service.

---

<div class="post-metadata">

### Author: ![Leopold\_O\_Donnell](https://avatars.discourse-cdn.com/v4/letter/l/c4cdca/32.png) [@Leopold\_O\_Donnell](https://community.wowza.com/u/Leopold_O_Donnell)
#### Post date: [February 11, 2012, 12:55pm UTC](https://community.wowza.com/t/ugh-bind-failed-try-again/37234/3 "2012-02-11T12:55:45Z")

</div>

> In Linux, it’s “netstat -p” to see the program associated with the port. You’ll have to figure out what that program is and stop it, change its port, or change Wowza’s port.
> 
> Check that you don’t have the Wowza service already loaded. Do “ps aux |grep java”. Look in the Wowza User Guide for info on how to start/stop the Wowza service.

Well

- netstat -p hasn’t identified any process

- no java processes running

- I’ve removed the server by deleting the installation from /usr/local

- I’ve re-installed

---

<div class="post-metadata">

### Author: ![Leopold\_O\_Donnell](https://avatars.discourse-cdn.com/v4/letter/l/c4cdca/32.png) [@Leopold\_O\_Donnell](https://community.wowza.com/u/Leopold_O_Donnell)
#### Post date: [February 11, 2012, 1:36pm UTC](https://community.wowza.com/t/ugh-bind-failed-try-again/37234/4 "2012-02-11T13:36:18Z")

</div>

Well - I did imply it was a dev server - looks like someone had tinkered with the Adobe FMS settings and it was running though not “obviously” using the port. You don’t see it in Netstat, but I think something funny happens with Wowza tries to compete at startup for ports etc.

Problem solved - another 2 hours of my life I won’t get back HA!
