# Ubuntu 15.04 install: Service fails to start with vague error message

**URL:** <https://community.wowza.com/t/ubuntu-15-04-install-service-fails-to-start-with-vague-error-message/45372>\
**Category:** Wowza Streaming Engine\
**Tags:** server-administration\
**Created:** [May 26, 2015, 2:36pm UTC](https://community.wowza.com/t/ubuntu-15-04-install-service-fails-to-start-with-vague-error-message/45372 "2015-05-26T14:36:12Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![doug\_shawhan](https://avatars.discourse-cdn.com/v4/letter/d/e19b73/32.png) [@doug\_shawhan](https://community.wowza.com/u/doug_shawhan)\
**Post date:** [May 26, 2015, 2:36pm UTC](https://community.wowza.com/t/ubuntu-15-04-install-service-fails-to-start-with-vague-error-message/45372/1 "2015-05-26T14:36:12Z")

</div>

Installed WSE on Ubuntu 15.04.

Installed with sudo ./WowzaStreamingEngine-4.1.2.deb.bin

```auto
Installing Wowza Streaming Engine
(Reading database ... 235795 files and directories currently installed.)
Preparing to unpack WowzaStreamingEngine-4.1.2.deb ...
Failed to stop WowzaStreamingEngine.service: Unit WowzaStreamingEngine.service not loaded.
Failed to stop WowzaStreamingEngineManager.service: Unit WowzaStreamingEngineManager.service not loaded.
	WowzaStreamingEngineManager: was not running.
rm: cannot remove ‘/var/lock/subsys/’: Is a directory
Unpacking wowzastreamingengine-4.1.2 (4.1.2-ga-1) over (4.1.2-ga-1) ...
Setting up wowzastreamingengine-4.1.2 (4.1.2-ga-1) ...
Start Wowza Streaming Engine automatically when this system reboots? [yes or no] 
yes
insserv: warning: current stop runlevel(s) (0 1 6) of script `WowzaStreamingEngineManager' overrides LSB defaults (0 1 6 S).
Starting WowzaStreamingEngine (via systemctl):
Failed to restart WowzaStreamingEngine.service: Unit WowzaStreamingEngine.service failed to load: No such file or directory.
Starting WowzaStreamingEngine (via systemctl):
Failed to restart WowzaStreamingEngineManager.service: Unit WowzaStreamingEngineManager.service failed to load: No such file or directory.
Install Location:
/usr/local/WowzaStreamingEngine
To access Wowza Streaming Engine Manager, go to http://localhost:8088/enginemanager in a web browser.

```

Attempting to start with

sudo service WowzaStreamingEngine start

```auto
Failed to start WowzaStreamingEngine.service: Unit WowzaStreamingEngine.service failed to load: No such file or directory.

```

I’m unsure why I was seeing “restart” in the installation, as I had not previously installed WSE. Any clues as to what file or directory is missing, and how I might fix this issue?

Thanks

---

<div class="post-metadata">

**Author:** ![doug\_shawhan](https://avatars.discourse-cdn.com/v4/letter/d/e19b73/32.png) [@doug\_shawhan](https://community.wowza.com/u/doug_shawhan)\
**Post date:** [May 26, 2015, 2:40pm UTC](https://community.wowza.com/t/ubuntu-15-04-install-service-fails-to-start-with-vague-error-message/45372/2 "2015-05-26T14:40:54Z")

</div>

I checked all the static scripts and paths in /etc/init.d/WowzaStreamingEngine and all exist.

---

<div class="post-metadata">

**Author:** ![sal\_jefferson](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@sal\_jefferson](https://community.wowza.com/u/sal_jefferson)\
**Post date:** [June 25, 2015, 7:38am UTC](https://community.wowza.com/t/ubuntu-15-04-install-service-fails-to-start-with-vague-error-message/45372/3 "2015-06-25T07:38:43Z")

</div>

We have found that when installing Wowza on the current Ubuntu server release 15.04 the Wowza services fail as part of the installation and do not start up automatically. This appears to be related to the recent move by Ubuntu from upstart to systemd,

[https://wiki.ubuntu.com/SystemdForUpstartUsers](https://wiki.ubuntu.com/SystemdForUpstartUsers)

A short term workaround is to run the following command, which basically re-installs upstart:

```auto
apt-get install upstart-sysv

```

Then start the Wowza install process over.

Alternatively, you can still restart Wowza via:

```auto
/etc/init.d/WowzaStreamingEngine start
/etc/init.d/WowzaStreamingEngineManager start

```

To avoid reinstalling upstart

I hope this helps.

Salvadore

---

<div class="post-metadata">

**Author:** ![Paul\_Shields](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/paul_shields/32/390_2.png) [@Paul\_Shields](https://community.wowza.com/u/Paul_Shields)\
**Post date:** [January 7, 2016, 6:09pm UTC](https://community.wowza.com/t/ubuntu-15-04-install-service-fails-to-start-with-vague-error-message/45372/4 "2016-01-07T18:09:50Z")

</div>

Hi,

Recent updates to Centos have caused issues with Wowza installations. This is due to their move to systemd. We aim to provide an updated installer soon to fix this but in the meantime we have documented this in our [known issues article](https://www.wowza.com/docs/important-issues-that-affect-wowza-streaming-engine-software#engine4) which also includes suggested workarounds.

Paul

---

<div class="post-metadata">

**Author:** ![Shaun\_Blair](https://avatars.discourse-cdn.com/v4/letter/s/a4c791/32.png) [@Shaun\_Blair](https://community.wowza.com/u/Shaun_Blair)\
**Post date:** [June 22, 2015, 3:28pm UTC](https://community.wowza.com/t/ubuntu-15-04-install-service-fails-to-start-with-vague-error-message/45372/5 "2015-06-22T15:28:56Z")

</div>

Did you find a solution? I’m running into the same issue.

---

<div class="post-metadata">

**Author:** ![Midhun\_Gopi](https://avatars.discourse-cdn.com/v4/letter/m/eb8c5e/32.png) [@Midhun\_Gopi](https://community.wowza.com/u/Midhun_Gopi)\
**Post date:** [January 1, 2016, 4:57pm UTC](https://community.wowza.com/t/ubuntu-15-04-install-service-fails-to-start-with-vague-error-message/45372/6 "2016-01-01T16:57:52Z")

</div>

I get a similar failure as mentioned in the thread, but in Cent OS 7.

Installing

0% \_\_\_\_\_\_\_\_\_\_\_\_\_\_ 50% \_\_\_\_\_\_\_\_\_\_\_\_\_\_ 100%

########################################Wowza Streaming Engine Setup - Warning: Problem running post-install step.

Installation may not complete correctly

Error running service WowzaStreamingEngine --full-restart: Failed to stop

WowzaStreamingEngine.service: Unit WowzaStreamingEngine.service not loaded.

Failed to start WowzaStreamingEngine.service: Unit WowzaStreamingEngine.service

failed to load: No such file or directory.

Press [Enter] to continue:

# 

* * *

Setup has finished installing Wowza Streaming Engine on your computer.

Any suggestions?

Midhun

---

<div class="post-metadata">

**Author:** ![snow\_flake](https://avatars.discourse-cdn.com/v4/letter/s/b5ac83/32.png) [@snow\_flake](https://community.wowza.com/u/snow_flake)\
**Post date:** [January 1, 2016, 10:29pm UTC](https://community.wowza.com/t/ubuntu-15-04-install-service-fails-to-start-with-vague-error-message/45372/7 "2016-01-01T22:29:01Z")

</div>

i upgraded to latest build and now im having this issue

[root@localhost linux]# /etc/init.d/WowzaStreamingEngine start

Reloading systemd: [OK]

Starting WowzaStreamingEngine (via systemctl): Failed to start WowzaStreamingEngine.service: Unit WowzaStreamingEngine.service failed to load: No such file or directory.

[FAILED]

[root@localhost linux]#

[root@localhost linux]# systemctl start WowzaStreamingEngine

Failed to start WowzaStreamingEngine.service: Unit WowzaStreamingEngine.service failed to load: No such file or directory.

[root@localhost linux]#

nothing is working i need a fix like ASAP im using centos latest version

---

<div class="post-metadata">

**Author:** ![snow\_flake](https://avatars.discourse-cdn.com/v4/letter/s/b5ac83/32.png) [@snow\_flake](https://community.wowza.com/u/snow_flake)\
**Post date:** [January 1, 2016, 10:44pm UTC](https://community.wowza.com/t/ubuntu-15-04-install-service-fails-to-start-with-vague-error-message/45372/8 "2016-01-01T22:44:59Z")

</div>

WOW even a reinstall doesnt fix issue…

---

<div class="post-metadata">

**Author:** ![snow\_flake](https://avatars.discourse-cdn.com/v4/letter/s/b5ac83/32.png) [@snow\_flake](https://community.wowza.com/u/snow_flake)\
**Post date:** [January 1, 2016, 11:39pm UTC](https://community.wowza.com/t/ubuntu-15-04-install-service-fails-to-start-with-vague-error-message/45372/9 "2016-01-01T23:39:48Z")

</div>

Thanks to centos and wowza tossing out a update they knew would break i have to reinstall an older linux and wowza… Awesome way to spend new years
