# Trying to connect s3 bucket.

**URL:** <https://community.wowza.com/t/trying-to-connect-s3-bucket/43450>\
**Category:** Wowza Streaming Engine\
**Created:** [July 29, 2014, 3:46am UTC](https://community.wowza.com/t/trying-to-connect-s3-bucket/43450 "2014-07-29T03:46:35Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![paul\_meeke](https://avatars.discourse-cdn.com/v4/letter/p/898d66/32.png) [@paul\_meeke](https://community.wowza.com/u/paul_meeke)\
**Post date:** [July 29, 2014, 3:46am UTC](https://community.wowza.com/t/trying-to-connect-s3-bucket/43450/1 "2014-07-29T03:46:35Z")

</div>

Hello i am trying to use the vod3 module on the ec2 instance of wowza to access files stored on my s3 bucket. I have edited the MediaCache.xml file and put in my awsAccessKeyId and awsSecretAccessKey but when i try and play myfile i get the error “source stream or file not found or access denied”

the file location in my s3 bucket is

```auto
https://s3.amazonaws.com/Mediaforwowza/Film/test.mp4

```

and the address in the player is

```auto
http://SERVER_IP:1935/vod3/_definst_/mp4:amazons3/Mediaforwowza/Film/test.mp4/manifest.f4m

```

or

```auto
http://SERVER_IP:1935/vod3/_definst_/mp4:amazons3/Mediaforwowza/Film/test.mp4

```

Any help with this would be greatly appreciated.

Thanks

---

<div class="post-metadata">

**Author:** ![paul\_meeke](https://avatars.discourse-cdn.com/v4/letter/p/898d66/32.png) [@paul\_meeke](https://community.wowza.com/u/paul_meeke)\
**Post date:** [July 29, 2014, 4:05am UTC](https://community.wowza.com/t/trying-to-connect-s3-bucket/43450/2 "2014-07-29T04:05:41Z")

</div>

Oh. I have also granted authenticated users to my s3 bucket, but this has not helped.

---

<div class="post-metadata">

**Author:** ![Jason\_Hilton](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/jason_hilton/32/437_2.png) [@Jason\_Hilton](https://community.wowza.com/u/Jason_Hilton)\
**Post date:** [July 30, 2014, 10:20am UTC](https://community.wowza.com/t/trying-to-connect-s3-bucket/43450/3 "2014-07-30T10:20:42Z")

</div>

Hi,

Thanks for the update, glad to hear that you have this working.

Regards,

Jason

---

<div class="post-metadata">

**Author:** ![Zoran](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/zoran/32/385_2.png) [@Zoran](https://community.wowza.com/u/Zoran)\
**Post date:** [July 29, 2014, 6:22pm UTC](https://community.wowza.com/t/trying-to-connect-s3-bucket/43450/4 "2014-07-29T18:22:19Z")

</div>

Hi,

Did you configure your Media Cache application using the instructions described in the “[How to scale video on demand streaming with Media Cache](https://www.wowza.com/docs/how-to-scale-video-on-demand-streaming-with-media-cache)” forum article?

Here is the [direct link](https://www.wowza.com/docs/how-to-scale-video-on-demand-streaming-with-media-cache#mediacacheconf_sourcesadds3) to the section describing how to add the S3 source.

Zoran

---

<div class="post-metadata">

**Author:** ![paul\_meeke](https://avatars.discourse-cdn.com/v4/letter/p/898d66/32.png) [@paul\_meeke](https://community.wowza.com/u/paul_meeke)\
**Post date:** [July 29, 2014, 4:43am UTC](https://community.wowza.com/t/trying-to-connect-s3-bucket/43450/5 "2014-07-29T04:43:47Z")

</div>

I tried opening the rtsp stream in vlc and got this error

```auto
RTSP connection failed:
Access to the stream is denied by the server configuration.
Your input can't be opened:
VLC is unable to open the MRL 'rtsp://SERVER_IP:1935/vod3/_definst_/amazons3/Mediaforwowza/Film/test.mp4'

```

---

<div class="post-metadata">

**Author:** ![paul\_meeke](https://avatars.discourse-cdn.com/v4/letter/p/898d66/32.png) [@paul\_meeke](https://community.wowza.com/u/paul_meeke)\
**Post date:** [July 29, 2014, 9:36am UTC](https://community.wowza.com/t/trying-to-connect-s3-bucket/43450/6 "2014-07-29T09:36:03Z")

</div>

> Hi,
> 
> Did you configure your Media Cache application using the instructions described in the “[How to scale video on demand streaming with Media Cache](https://www.wowza.com/docs/how-to-scale-video-on-demand-streaming-with-media-cache)” forum article?
> 
> Here is the [direct link](https://www.wowza.com/docs/how-to-scale-video-on-demand-streaming-with-media-cache#mediacacheconf_sourcesadds3) to the section describing how to add the S3 source.
> 
> Zoran

Hello thanks for the reply.

I followed these steps an i think i have found the problem. the check box which states “use amazon S3 bucket name in domain” is checked. When this is checked i notice the address resolved is wrong for finding the file on the bucked as the address given is,

```auto
http://mybucket.s3.amazonaws.com/mypath/sample.mp4

```

But when it is unchecked the domain is correct.

```auto
http://s3.amazonaws.com/mybucket/mypath/sample.mp4

```

Only problem is i cannot seem to uncheck this button, i uncheck it, save my config, and re-enter into config page and see that the button is checked again?

---

<div class="post-metadata">

**Author:** ![paul\_meeke](https://avatars.discourse-cdn.com/v4/letter/p/898d66/32.png) [@paul\_meeke](https://community.wowza.com/u/paul_meeke)\
**Post date:** [July 29, 2014, 10:11am UTC](https://community.wowza.com/t/trying-to-connect-s3-bucket/43450/7 "2014-07-29T10:11:21Z")

</div>

I have managed to remove this checkbox manually by editing the MediaCache.xml file and changing the value from true to false as shown below. I can view the stream directly with the link provided [http://SERVER\_IP:8088/enginemanager/Home.htm#server/_defaultVHost_/mediaCache](http://SERVER_IP:8088/enginemanager/Home.htm#server/_defaultVHost_/mediaCache) ----\> Validate Configuration but not when trying to use the server address in the test player or vlc the file will still not play.

```auto
<Property>
<Name>s3BucketNameInDomain</Name>
<Value>false</Value>
<Type>Boolean</Type>
</Property>

```

---

<div class="post-metadata">

**Author:** ![paul\_meeke](https://avatars.discourse-cdn.com/v4/letter/p/898d66/32.png) [@paul\_meeke](https://community.wowza.com/u/paul_meeke)\
**Post date:** [July 29, 2014, 12:37pm UTC](https://community.wowza.com/t/trying-to-connect-s3-bucket/43450/8 "2014-07-29T12:37:05Z")

</div>

I have noticed a few errors in the log file which appear each time i try and play the file, maybee they can help.

```auto
Application folder ([install-location]/applications/vod3) is missing
WARN	server	comment	2014-07-29	20:32:02	-	-	-	-	-	9313.413	-	-	-	-	--	-	-	HTTPStreamerAdapterSanJoseStreamer.onPlaylist: Application context not loaded [[vod3/_definst_/mp4:amazons3/Mediaforwowza/Film/BigBuckBunny_115k.mov/manifest.f4m]: vod3/_definst_]: vod3/_definst_

```

---

<div class="post-metadata">

**Author:** ![paul\_meeke](https://avatars.discourse-cdn.com/v4/letter/p/898d66/32.png) [@paul\_meeke](https://community.wowza.com/u/paul_meeke)\
**Post date:** [July 29, 2014, 12:42pm UTC](https://community.wowza.com/t/trying-to-connect-s3-bucket/43450/9 "2014-07-29T12:42:28Z")

</div>

just asnswered my own question and have it working now

```auto
([install-location]/applications/[COLOR="#FF0000"]vod3[/COLOR]) is missing

```

tells me i have a spelling error “vod3” should be “vods3”

Got it working FINALLY!!
