# Startup Streams Monitor Module Error

**URL:** <https://community.wowza.com/t/startup-streams-monitor-module-error/42037>\
**Category:** Wowza Streaming Engine\
**Created:** [February 13, 2014, 2:24am UTC](https://community.wowza.com/t/startup-streams-monitor-module-error/42037 "2014-02-13T02:24:14Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mayank\_Srivastava](https://avatars.discourse-cdn.com/v4/letter/m/838e76/32.png) [@Mayank\_Srivastava](https://community.wowza.com/u/Mayank_Srivastava)\
**Post date:** [February 13, 2014, 2:24am UTC](https://community.wowza.com/t/startup-streams-monitor-module-error/42037/1 "2014-02-13T02:24:14Z")

</div>

Hi,

I had used the below link to setup ServerListenerStartupStreamsMonitor to monitor content folder for stream files and start stream whenever new file is detected.

[https://www.wowza.com/docs/how-to-monitor-content-folder-for-sdp-and-stream-files-to-start-publishing-streams-serverlistenerstartupstreamsmonitor](https://www.wowza.com/docs/how-to-monitor-content-folder-for-sdp-and-stream-files-to-start-publishing-streams-serverlistenerstartupstreamsmonitor)

This setup used to work well with WMS 3.6.4.

But with Wowza Streaming Engine 4.0.0, the following error shows on server startup.

INFO server comment - ServerListenerStartupStreamsMonitor.onServerInit

INFO server comment - MediaCasterStreamValidator.init[live/_definst_]: Started

INFO server comment - ModuleCoreSecurity.onAppStart[live/_definst_]: Publish: AllowedEncoders: securityPublishValidEncoders:Wirecast/|FME/|FMLE/

INFO server comment - ModuleCoreSecurity.onAppStart[live/_definst_]: Publish: block duplicate stream names : false

INFO server comment - ModuleCoreSecurity.onAppStart[live/_definst_]: Play: SecureConnection: securityPlayRequireSecureConnection:false

INFO application app-start _definst_ live/_definst_

**INFO server comment - ServerListenerStartupStreamsMonitor: Add application instance: _defaultVHost_:live/_definst_**

**Error starting: java.lang.reflect.InvocationTargetException**

**java.lang.reflect.InvocationTargetException**

**at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)**

**at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)**

**at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)**

**at java.lang.reflect.Method.invoke(Unknown Source)**

**at com.wowza.wms.bootstrap.Bootstrap.startServer(Bootstrap.java:346)**

**at com.wowza.wms.bootstrap.Bootstrap.main(Bootstrap.java:40)**

**Caused by: java.lang.ClassCastException: java.lang.Boolean cannot be cast to java.lang.String**

**at com.wowza.wms.application.WMSProperties.getPropertyStr(WMSProperties.java:108)**

**at com.wowza.wms.serverlistener.ServerListenerStartupStreamsMonitor$StartupStreamsAppInstance.init(ServerListenerStartupStreamsMonitor.java:266)**

**at com.wowza.wms.serverlistener.ServerListenerStartupStreamsMonitor.onServerInit(ServerListenerStartupStreamsMonitor.java:840)**

**at com.wowza.wms.server.Server.l(Server.java:2947)**

**at com.wowza.wms.server.Server.start(Server.java:1003)**

**… 6 more**

Urgent help needed as this is affecting our production.

---

<div class="post-metadata">

**Author:** ![Jason\_Hilton](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/jason_hilton/32/437_2.png) [@Jason\_Hilton](https://community.wowza.com/u/Jason_Hilton)\
**Post date:** [February 13, 2014, 10:44am UTC](https://community.wowza.com/t/startup-streams-monitor-module-error/42037/2 "2014-02-13T10:44:24Z")

</div>

Hi,

Please open a ticket by sending an email to support@wowza.com.

Include a zipped copy of the [Wowza-Install]/conf and [Wowza-Install]/logs so that we can investigate this issue further and a link to this thread for reference.

Thanks

Jason

---

<div class="post-metadata">

**Author:** ![Jason\_Hilton](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/jason_hilton/32/437_2.png) [@Jason\_Hilton](https://community.wowza.com/u/Jason_Hilton)\
**Post date:** [February 14, 2014, 9:48am UTC](https://community.wowza.com/t/startup-streams-monitor-module-error/42037/3 "2014-02-14T09:48:38Z")

</div>

Hi,

That’s great news, thanks for the update.

I’m glad it’s working for you.

Jason

---

<div class="post-metadata">

**Author:** ![Mayank\_Srivastava](https://avatars.discourse-cdn.com/v4/letter/m/838e76/32.png) [@Mayank\_Srivastava](https://community.wowza.com/u/Mayank_Srivastava)\
**Post date:** [February 13, 2014, 11:01pm UTC](https://community.wowza.com/t/startup-streams-monitor-module-error/42037/4 "2014-02-13T23:01:50Z")

</div>

Hi Jason,

This is no longer required. It was an auto-merge error from our end. While merging conf files one of the tag was left opened. Guess we shouldn’t have merged the configuration files, instead added configurations ourselves.

Thanks for a prompt response.

Mayank

---

<div class="post-metadata">

**Author:** ![Mayank\_Srivastava](https://avatars.discourse-cdn.com/v4/letter/m/838e76/32.png) [@Mayank\_Srivastava](https://community.wowza.com/u/Mayank_Srivastava)\
**Post date:** [March 20, 2014, 2:46am UTC](https://community.wowza.com/t/startup-streams-monitor-module-error/42037/5 "2014-03-20T02:46:02Z")

</div>

Hi Jason,

I have created a HTTPProvider to create and start applications on the fly (using [java.io](http://java.io)).

Now additionally, I want that when this application is created its content folder also starts getting monitored by this listener. I don’t want to restart wowza server due to production reasons.

Mayank.
