# Server Error: Unable to establish loopback connection

**URL:** <https://community.wowza.com/t/server-error-unable-to-establish-loopback-connection/41453>\
**Category:** Wowza Streaming Engine\
**Created:** [October 30, 2013, 3:30pm UTC](https://community.wowza.com/t/server-error-unable-to-establish-loopback-connection/41453 "2013-10-30T15:30:40Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Cristiano\_Costa\_de\_S](https://avatars.discourse-cdn.com/v4/letter/c/958977/32.png) [@Cristiano\_Costa\_de\_S](https://community.wowza.com/u/Cristiano_Costa_de_S)\
**Post date:** [October 30, 2013, 3:30pm UTC](https://community.wowza.com/t/server-error-unable-to-establish-loopback-connection/41453/1 "2013-10-30T15:30:40Z")

</div>

Hi.

I’m having a trouble with Wowza Media Server 2.2.4.07.

**First** , after the server machine turn on, Wowza works fine, but after about 3 days, media content and administration port doesn’t work. Access and error logs generates the following message:

```auto
java.io.IOException: Unable to establish loopback connection
	at sun.nio.ch.PipeImpl$Initializer.run(PipeImpl.java:125)
	at sun.nio.ch.PipeImpl$Initializer.run(PipeImpl.java:69)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.nio.ch.PipeImpl.<init>(PipeImpl.java:141)
	at sun.nio.ch.SelectorProviderImpl.openPipe(SelectorProviderImpl.java:50)
	at java.nio.channels.Pipe.open(Pipe.java:150)
	at sun.nio.ch.WindowsSelectorImpl.<init>(WindowsSelectorImpl.java:126)
	at sun.nio.ch.WindowsSelectorProvider.openSelector(WindowsSelectorProvider.java:44)
	at java.nio.channels.Selector.open(Selector.java:227)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.startupWorker(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketIoProcessor.addNew(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketAcceptor$Worker.processSessions(Unknown Source)
	at org.apache.mina.transport.socket.nio.SocketAcceptor$Worker.run(Unknown Source)
	at org.apache.mina.util.NamePreservingRunnable.run(Unknown Source)
	at java.lang.Thread.run(Thread.java:724)
Caused by: java.net.SocketException: No buffer space available (maximum connections reached?): bind
	at sun.nio.ch.Net.bind0(Native Method)
	at sun.nio.ch.Net.bind(Net.java:444)
	at sun.nio.ch.Net.bind(Net.java:436)
	at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:214)
	at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
	at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:67)
	at sun.nio.ch.PipeImpl$Initializer.run(PipeImpl.java:91)
	... 14 more

```

**Second** , I try to restart service, but without luck. Error log generate, in addition of above, the following messages:

```auto
ERROR	server	comment	2013-10-30	11:10:20	-	-	-	-	-	0.594	-	-	-	-	-	-	-	-	server core failure: java.io.IOException: Unable to establish loopback connection
WARN	vhost	comment	2013-10-30	11:10:41	-	-	-	-	-	20.984	-	-	-	-	-	-	-	_defaultVHost_	Bind failed: ([any]:1935): java.io.IOException: Unable to establish loopback connection
WARN	vhost	comment	2013-10-30	11:10:41	-	-	-	-	-	20.984	-	-	-	-	-	-	-	_defaultVHost_	Bind failed: ([any]:8086): java.io.IOException: Unable to establish loopback connection

```

**Third** , when the problem is occurring, to check tcp connections of the server, I use the command line “netstat -s” and note that “TCP Statistics for IPv4 -\> Current Connections” has a low value (about 60)

**Fourth** , I also have tried [this post’s solution](https://www.wowza.com/forums/showthread.php?14911-Server-error&p=76648#post76648), adjusting TcpTimedWaitDelay to 30, and I’ve tried too [this another post’s solution](https://www.wowza.com/forums/showthread.php?7105-quot-server-core-failure-quot-when-starting-server&p=32593#post32593).

Both attemps without luck.

PS.: Running in Windows Server 2003 R2 x64, java 7 u25

Thanks in advance.

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [October 30, 2013, 6:48pm UTC](https://community.wowza.com/t/server-error-unable-to-establish-loopback-connection/41453/2 "2013-10-30T18:48:37Z")

</div>

Try editing conf/Server.xml and conf/VHost.xml and change the IpAddress value in all places to either 127.0.0.1 or the interal ip address of the server. It seems to be trying to bind to the local loop back controller that is causing problems.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [October 31, 2013, 2:05pm UTC](https://community.wowza.com/t/server-error-unable-to-establish-loopback-connection/41453/3 "2013-10-31T14:05:10Z")

</div>

What do you get when you do “ping loopback” in console?

Have you tried the IPv6 loopback address “::1” ?

Richard

---

<div class="post-metadata">

**Author:** ![Cristiano\_Costa\_de\_S](https://avatars.discourse-cdn.com/v4/letter/c/958977/32.png) [@Cristiano\_Costa\_de\_S](https://community.wowza.com/u/Cristiano_Costa_de_S)\
**Post date:** [October 31, 2013, 9:10am UTC](https://community.wowza.com/t/server-error-unable-to-establish-loopback-connection/41453/4 "2013-10-31T09:10:29Z")

</div>

I already tried that, no success. Another suggestion?

---

<div class="post-metadata">

**Author:** ![Cristiano\_Costa\_de\_S](https://avatars.discourse-cdn.com/v4/letter/c/958977/32.png) [@Cristiano\_Costa\_de\_S](https://community.wowza.com/u/Cristiano_Costa_de_S)\
**Post date:** [November 6, 2013, 1:57pm UTC](https://community.wowza.com/t/server-error-unable-to-establish-loopback-connection/41453/5 "2013-11-06T13:57:58Z")

</div>

Thanks for reply.

With the server working normally, i can do “ping loopback” with success.

But when the problem occured for the last time, there wasn’t me who checked the server, so, I couldn’t test ‘ping loopback’ again.

But I think I found the solution.

I had to add the two values to the Windows Registry:

“HKEY\_LOCAL\_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\MaxUserPort” (Type: DWORD; Value: 65500)

“HKEY\_LOCAL\_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\TcpTimedWaitDelay” (Type: DWORD; Value: 30 )

Until now, this problem didn’t occur after making this change.

Thanks.
