# Problem on Jconsole Startup

**URL:** https://community.wowza.com/t/problem-on-jconsole-startup/40202
**Category:** Wowza Streaming Engine
**Tags:** server-administration
**Created:** [May 14, 2013, 11:57am UTC](https://community.wowza.com/t/problem-on-jconsole-startup/40202 "2013-05-14T11:57:44Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Thanaphum\_Sukanjanas](https://avatars.discourse-cdn.com/v4/letter/t/f4b2a3/32.png) [@Thanaphum\_Sukanjanas](https://community.wowza.com/u/Thanaphum_Sukanjanas)
#### Post date: [May 14, 2013, 11:57am UTC](https://community.wowza.com/t/problem-on-jconsole-startup/40202/1 "2013-05-14T11:57:44Z")

</div>

Hi Wowza team

I just got some problem on Jconsole since I am using Virtual private server to run Wowza.

The configuration on Server.html is here.

true

122.155.15.xxx

122.155.15.xxx

8084

8085

true

${com.wowza.wms.ConfigHome}/conf/jmxremote.password

${com.wowza.wms.ConfigHome}/conf/jmxremote.access

false

However, I got the error during running Jconsole and the error has been shown

**ERROR 500 - JMXConfig: error: java.io.IOException: Cannot bind to URL [rmi://122.155.15.xxx:8085/jmxrmi]: javax.naming.ServiceUnavailableException [Root exception is java.rmi.ConnectException: Connection refused to host: 122.155.15.xxx; nested exception is:**

**java.net.ConnectException: Connection timed out: connect]**

Port 8084 and 8085 have been opened already but still cannot access to Jconsole.

Could you please help me figure out?

Thanks

Mark

---

<div class="post-metadata">

### Author: ![sal\_jefferson](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@sal\_jefferson](https://community.wowza.com/u/sal_jefferson)
#### Post date: [May 14, 2013, 6:03pm UTC](https://community.wowza.com/t/problem-on-jconsole-startup/40202/2 "2013-05-14T18:03:47Z")

</div>

Hi there, it looks like you are trying to run jconsole at the same location as your wowza install?

Can you get it to work if you set authenticate to false false and use the default url to connect? :

service:jmx:rmi://localhost:8084/jndi/rmi://localhost:8085/jmxrmi

This just worked for me

Salvadore

---

<div class="post-metadata">

### Author: ![sal\_jefferson](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@sal\_jefferson](https://community.wowza.com/u/sal_jefferson)
#### Post date: [May 15, 2013, 6:49am UTC](https://community.wowza.com/t/problem-on-jconsole-startup/40202/3 "2013-05-15T06:49:29Z")

</div>

I did a little more work with this, and also realized its not a good idea to not use authentication.

So leave authentication enabled, use the default url: **service:jmx:rmi://localhost:8084/jndi/rmi://localhost:8085/jmxrmi**

and the default user name is: admin and password: admin

Also make sure wowza is started.

You could work through this guide to make sure you are setting this up correctly,

[Enable JMX in Wowza Media Server](https://www.wowza.com/docs/how-to-install-and-configure-wowza-streaming-engine#jconsole)

Salvadore
