# NVENC initialization errors with Wowza 4.7.1 and CentOS 7

**URL:** <https://community.wowza.com/t/nvenc-initialization-errors-with-wowza-4-7-1-and-centos-7/50357>\
**Category:** Wowza Streaming Engine\
**Created:** [December 12, 2017, 11:59pm UTC](https://community.wowza.com/t/nvenc-initialization-errors-with-wowza-4-7-1-and-centos-7/50357 "2017-12-12T23:59:32Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Carl\_Burmeister](https://avatars.discourse-cdn.com/v4/letter/c/958977/32.png) [@Carl\_Burmeister](https://community.wowza.com/u/Carl_Burmeister)\
**Post date:** [December 12, 2017, 11:59pm UTC](https://community.wowza.com/t/nvenc-initialization-errors-with-wowza-4-7-1-and-centos-7/50357/1 "2017-12-12T23:59:32Z")

</div>

We are seeing the following lines in the access log when trying to use NVENC GPU encoding with Wowza 4.7.1 and CentOS 7.

2017-12-1219:17:46UTCcommentserverWARN200-JNI:VideoEncoderH26XNVENC.initialize[_defaultVHost_:test/_definst_/tera01\_live.stream:1000\_Encode]: Initialize failed: gpuid:0 result:10—2849.724----------------

2017-12-1219:17:46UTCcommentserverWARN200-TranscoderWorkerVideoEncoder.setupEncoder[_defaultVHost_:test/_definst_/tera01\_live.stream:1000\_Encode]: Error videoEncoderInitialize[H264]: 4294967292—2849.724--------------

The GPU is an NVidia Quadro K4000.

The Nvidia drivers tried are: 381.22 and 384.98 (latest version).

There are two of them installed. The same errors occur when setting -1 in the transcoder template.

Logs, transcoder template, and application.xml files attached.

Are there any special server configuration steps required to use NVENC with CentOS 7?

---

<div class="post-metadata">

**Author:** ![Andrew\_Ramberg](https://avatars.discourse-cdn.com/v4/letter/a/7c8e57/32.png) [@Andrew\_Ramberg](https://community.wowza.com/u/Andrew_Ramberg)\
**Post date:** [December 17, 2017, 2:58am UTC](https://community.wowza.com/t/nvenc-initialization-errors-with-wowza-4-7-1-and-centos-7/50357/2 "2017-12-17T02:58:30Z")

</div>

Hello,

Our QA Team has not yet released testing on CentOS 7 so we don’t officially support this version.

We do have instructions on how to use NVENC Transcoding on the older CentOS 6.4 and this has been tested as a known working configuration. Please see the following [instructions for CentOS 6.4](https://www.wowza.com/docs/How-to-set-up-Wowza-Transcoder-NVIDIA-NVENC-accelerated-encoding-on-CentOS).

Otherwise, you could also try using Ubuntu or another more recent Linux variant. See the following [page](https://www.wowza.com/docs/how-to-configure-nvenc-accelerated-encoding-on-linux) for more options.

Best regards,  
Andrew
