# I distributed it to an Amazon EC2 instance, but I can't publish it. Please help me

**URL:** https://community.wowza.com/t/i-distributed-it-to-an-amazon-ec2-instance-but-i-cant-publish-it-please-help-me/93925
**Category:** Wowza Streaming Engine
**Tags:** wowza-streaming-server-java-api, webrtc
**Created:** [October 7, 2021, 5:31am UTC](https://community.wowza.com/t/i-distributed-it-to-an-amazon-ec2-instance-but-i-cant-publish-it-please-help-me/93925 "2021-10-07T05:31:17Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Park\_Sanghyun1](https://avatars.discourse-cdn.com/v4/letter/p/35a633/32.png) [@Park\_Sanghyun1](https://community.wowza.com/u/Park_Sanghyun1)
#### Post date: [October 7, 2021, 5:31am UTC](https://community.wowza.com/t/i-distributed-it-to-an-amazon-ec2-instance-but-i-cant-publish-it-please-help-me/93925/1 "2021-10-07T05:31:17Z")

</div>

Hello,

I created a wowza (BYOL) instance on Amazon ec2 and was able to successfully manipulate enginmanager.

I tried to set up a virtual host and application by referring to the following YouTube video.

[webRTC guide](https://www.youtube.com/watch?v=fIT9fRSbZmQ)

 ![image](https://us1.discourse-cdn.com/flex002/uploads/wowza1/original/1X/74c1f4ea6a96cc0509fc6069b3157524cebcfeb6.png)

There was a slight issue in setting up a virtual host while following the guide of the video.  
I set the Elastic IP of the instance I created and assigned to the ip address of the streamlock,  
but I checked the error log as below

------ error log ------  
_defaultVHost_ Bind failed, try again (13.209.234.145:443): java.net.BindException: Cannot assign requested address.  
------ error log ------

Therefore, when I set it to localhost and restarted the server as in the attached picture, there was no special error.  
After that, the application was set up and public tested according to the remaining guide, but the socket connection continued to cause problems.  
I followed all the instructions in the guide, and the only difference from what I tried in the guide is the ip address of the virtual host.

I connected to the created wowza instance in the ssh environment, and the ping test was not performed with that IP.  
The security group has been set up to allow all ports that the engine manager may need and ports that I have checked while looking for to solve this problem. What am I missing out on?

---

<div class="post-metadata">

### Author: ![Park\_Sanghyun1](https://avatars.discourse-cdn.com/v4/letter/p/35a633/32.png) [@Park\_Sanghyun1](https://community.wowza.com/u/Park_Sanghyun1)
#### Post date: [October 7, 2021, 8:47am UTC](https://community.wowza.com/t/i-distributed-it-to-an-amazon-ec2-instance-but-i-cant-publish-it-please-help-me/93925/2 "2021-10-07T08:47:03Z")

</div>

sorry  
i Solved it myself  
I got a hint from the answer to the following question that there is no need to set the IP of the virtual host, and I tried it and it works.

[http://community.wowza.com/t/cannot-assign-requested-address/42143](http://community.wowza.com/t/cannot-assign-requested-address/42143)

Thanks everyone!
