# How To create Dynamic Playlist

**URL:** <https://community.wowza.com/t/how-to-create-dynamic-playlist/36177>\
**Category:** Wowza Streaming Engine\
**Created:** [October 21, 2011, 4:24pm UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177 "2011-10-21T16:24:08Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ravi\_Gupta](https://avatars.discourse-cdn.com/v4/letter/r/e56c9b/32.png) [@Ravi\_Gupta](https://community.wowza.com/u/Ravi_Gupta)\
**Post date:** [October 21, 2011, 4:24pm UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/1 "2011-10-21T16:24:08Z")

</div>

Hello I have seen Stream Class Module but it is not running and i want to create dynamic playlist

Help Me

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [October 21, 2011, 3:51pm UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/2 "2011-10-21T15:51:03Z")

</div>

Try this one:

[https://www.wowza.com/docs/how-to-schedule-streaming-with-wowza-streaming-engine-streampublisher](https://www.wowza.com/docs/how-to-schedule-streaming-with-wowza-streaming-engine-streampublisher)

It is configurable, you can download the collection jar to get it without building any code, and there are many posts discussing its use:

Richard

---

<div class="post-metadata">

**Author:** ![shekar\_KCB](https://avatars.discourse-cdn.com/v4/letter/s/4da419/32.png) [@shekar\_KCB](https://community.wowza.com/u/shekar_KCB)\
**Post date:** [October 28, 2011, 10:46pm UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/3 "2011-10-28T22:46:42Z")

</div>

I don’t see ‘live/Stream1’ staring as soon as wowza is started,

Are you sure you have added

```auto
<ServerListener>
	<BaseClass>com.wowza.wms.plugin.collection.serverlistener.ServerListenerStreamPublisher</BaseClass>
</ServerListener>

```

to /conf/Server.xml ?

This module in default streams to application called ‘live’ with Stream name ‘Stream1’ or the name you have specified under ‘/content/streamschedule.smil’ file.

Make sure you have created application called ‘live’ under ‘/conf/’ and ‘/applications/’.

–

ShekarKCB

---

<div class="post-metadata">

**Author:** ![Ravi\_Gupta](https://avatars.discourse-cdn.com/v4/letter/r/e56c9b/32.png) [@Ravi\_Gupta](https://community.wowza.com/u/Ravi_Gupta)\
**Post date:** [October 22, 2011, 2:55pm UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/4 "2011-10-22T14:55:33Z")

</div>

hi ,

I have see this link and

add

com.wowza.wms.plugin.collection.serverlistener.ServerListenerStreamPublisher

into server.xml file and restart Wowza it show

Configure logging: file:///usr/local/WowzaMediaServer/conf/log4j.properties

INFO server server-start Wowza Media Server 3 Trial Edition (Expires: Nov 21, 2011) 3.0.2 build866 -

INFO server comment - Server License Key: SVRT3-XXXXX-XXXXX-XXXXX-XXXXX-yb9Kf

INFO server comment - Maximum Connections: Unlimited

INFO server comment - Transcoder Streams Available: Unlimited

INFO server comment - Transcoder Watermark: Yes

INFO server comment - nDVR Available: Yes

INFO server comment - DRM Available: Yes

INFO server comment - Hardware Available Processors: 4

INFO server comment - Hardware Physical Memory: 46MB/1869MB

INFO server comment - Hardware Swap Space: 5882MB/5887MB

INFO server comment - Max File Descriptor Count: 20000

INFO server comment - Open File Descriptor Count: 55

INFO server comment - OS Name: Linux

INFO server comment - OS Version: 2.6.35.13-92.fc14.x86\_64

INFO server comment - OS Architecture: amd64

INFO server comment - Java Name: OpenJDK 64-Bit Server VM

INFO server comment - Java Vendor: Sun Microsystems Inc.

INFO server comment - Java Version: 1.6.0\_20

INFO server comment - Java VM Version: 19.0-b09

INFO server comment - Java Spec Version: 1.6

INFO server comment - Java Home: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86\_64/jre

INFO server comment - Java Max Heap Size: 1066MB

INFO server comment - Java Architecture: 64

INFO server comment - Java Encoding[file.encoding]: UTF-8

INFO server comment - Java Args[0]: -Xmx1200M

INFO server comment - Java Args[1]: -Djava.net.preferIPv4Stack=true

INFO server comment - Java Args[2]: -Dcom.sun.management.jmxremote=true

INFO server comment - Java Args[3]: -Dcom.wowza.wms.runmode=standalone

INFO server comment - Java Args[4]: -Dcom.wowza.wms.native.base=linux

INFO server comment - Java Args[5]: -Dcom.wowza.wms.AppHome=/usr/local/WowzaMediaServer

INFO server comment - Java Args[6]: -Dcom.wowza.wms.ConfigURL=

INFO server comment - Java Args[7]: -Dcom.wowza.wms.ConfigHome=/usr/local/WowzaMediaServer

INFO server comment - Java GC[0]: PS Scavenge

INFO server comment - Java GC[1]: PS MarkSweep

INFO server comment - Server runmode: standalone

INFO server comment - Server native.platform: linux

INFO server comment - Server threads[h/t]: 10/10

INFO server comment - CMDInterface now listening: [any]:8083

INFO vhost vhost-start _defaultVHost_ -

INFO server comment - _defaultVHost_ threads[h/t]:120/80 home:/usr/local/WowzaMediaServer

INFO vhost comment _defaultVHost_ Bind attempt ([any]:1935:4)

INFO vhost comment _defaultVHost_ Bind successful ([any]:1935)

INFO vhost comment _defaultVHost_ Bind attempt ([any]:8086:1)

INFO vhost comment _defaultVHost_ Bind successful ([any]:8086)

INFO server comment - -

INFO server comment - Wowza Media Server is started!

but when i do to **play** open [install-dir]/examples/LiveVideoStreaming/client/live.html

**Server:** rtmp://[wowza-address]/live

**Stream:** Stream1

it show on html page Stream1 not found but on terminal show stream create

What is actual problem

---

<div class="post-metadata">

**Author:** ![Ravi\_Gupta](https://avatars.discourse-cdn.com/v4/letter/r/e56c9b/32.png) [@Ravi\_Gupta](https://community.wowza.com/u/Ravi_Gupta)\
**Post date:** [October 31, 2011, 4:08pm UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/5 "2011-10-31T16:08:02Z")

</div>

i do this but this error is occur now

INFO server comment - ServerListenerStreamPublisher Started.

WARN server comment - ApplicationInstance.setHTTPStreamerList[live/_definst_]: HTTPStreamer is not valid: sanjosestreaming

WARN server comment - ApplicationInstance.setLiveStreamPacketizerList[live/_definst_]: LiveStreamPacketizer is not valid: sanjosestreamingpacketizer

INFO application app-start _definst_ live/_definst_

INFO server comment - ServerListenerStreamPublisher: Streame name is ‘Stream1’

log4j:ERROR Failed to excute sql

com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘Stream1’’, ‘-’, ‘-’, ‘-’, ‘33.277’, ‘-’, ‘-’, ‘-’, ‘-’, ‘-’, ‘-’, ‘-’, ‘-’, ‘-’,’ at line 1

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)

at java.lang.reflect.Constructor.newInstance(Constructor.java:513)

at com.mysql.jdbc.Util.handleNewInstance(Util.java:407)

at com.mysql.jdbc.Util.getInstance(Util.java:382)

at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1052)

at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3603)

at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3535)

at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1989)

at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2150)

at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2620)

at com.mysql.jdbc.StatementImpl.executeUpdate(StatementImpl.java:1664)

at com.mysql.jdbc.StatementImpl.executeUpdate(StatementImpl.java:1583)

at org.apache.log4j.jdbc.JDBCAppender.execute(Unknown Source)

at org.apache.log4j.jdbc.JDBCAppender.flushBuffer(Unknown Source)

at org.apache.log4j.jdbc.JDBCAppender.append(Unknown Source)

at org.apache.log4j.AppenderSkeleton.doAppend(Unknown Source)

at org.apache.log4j.helpers.AppenderAttachableImpl.appendLoopOnAppenders(Unknown Source)

at org.apache.log4j.Category.callAppenders(Unknown Source)

at org.apache.log4j.Category.forcedLog(Unknown Source)

at org.apache.log4j.Category.log(Unknown Source)

at com.wowza.wms.logging.WMSLogger.log(Unknown Source)

at com.wowza.wms.logging.WMSLogger.info(Unknown Source)

at com.wowza.wms.plugin.collection.serverlistener.ServerListenerStreamPublisher.onServerInit(ServerListenerStreamPublisher.java:103)

at com.wowza.wms.server.Server.notifyServerInit(Unknown Source)

at com.wowza.wms.server.Server.start(Unknown Source)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:597)

at com.wowza.wms.bootstrap.Bootstrap.startServer(Unknown Source)

at com.wowza.wms.bootstrap.Bootstrap.main(Unknown Source)

INFO stream create - -

INFO stream publish Stream1 -

INFO server comment - ServerListenerStreamPublisher: Streame name is ‘Stream2’

INFO stream create - -

INFO stream publish Stream2 -

Error starting: java.lang.reflect.InvocationTargetException

java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:597)

at com.wowza.wms.bootstrap.Bootstrap.startServer(Unknown Source)

at com.wowza.wms.bootstrap.Bootstrap.main(Unknown Source)

Caused by: java.lang.NoSuchMethodError: com.wowza.wms.stream.publish.Stream.setSendOnMetadata(Z)V

at com.wowza.wms.plugin.collection.serverlistener.ServerListenerStreamPublisher.onServerInit(ServerListenerStreamPublisher.java:159)

at com.wowza.wms.server.Server.notifyServerInit(Unknown Source)

at com.wowza.wms.server.Server.start(Unknown Source)

… 6 more

---

<div class="post-metadata">

**Author:** ![Ravi\_Gupta](https://avatars.discourse-cdn.com/v4/letter/r/e56c9b/32.png) [@Ravi\_Gupta](https://community.wowza.com/u/Ravi_Gupta)\
**Post date:** [October 31, 2011, 4:33pm UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/6 "2011-10-31T16:33:59Z")

</div>

hi my server.xml file is like this

com.wowza.wms.plugin.amazonaws.ec2.env.ServerListenerEC2Variables

com.wowza.wms.plugin.amazonaws.ec2.mediacache.MediaCacheServerListenerAmazonEC2

com.wowza.wms.plugin.collection.serverlistener.ServerListenerStreamPublisher

till Now error is occur same , Plz Help me

---

<div class="post-metadata">

**Author:** ![Ravi\_Gupta](https://avatars.discourse-cdn.com/v4/letter/r/e56c9b/32.png) [@Ravi\_Gupta](https://community.wowza.com/u/Ravi_Gupta)\
**Post date:** [October 31, 2011, 4:58pm UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/7 "2011-10-31T16:58:45Z")

</div>

then what should i do for better result

My Wowza Version is Wowza Media Server 2 for Amazon EC2 2.1.1 build24490

---

<div class="post-metadata">

**Author:** ![Ravi\_Gupta](https://avatars.discourse-cdn.com/v4/letter/r/e56c9b/32.png) [@Ravi\_Gupta](https://community.wowza.com/u/Ravi_Gupta)\
**Post date:** [November 1, 2011, 10:48am UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/8 "2011-11-01T10:48:46Z")

</div>

firstly i had try to trial version on wowza 3

Now i want to do same task on Wowza Media Server 2 for Amazon EC2 2.1.1

So problem is occurring

---

<div class="post-metadata">

**Author:** ![Jason\_Hilton](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/jason_hilton/32/437_2.png) [@Jason\_Hilton](https://community.wowza.com/u/Jason_Hilton)\
**Post date:** [October 31, 2011, 10:55am UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/9 "2011-10-31T10:55:31Z")

</div>

> Try this one:
> 
> [Schedule streaming](https://www.wowza.com/docs/how-to-schedule-streaming-with-wowza-streaming-engine-streampublisher)
> 
> It is configurable, you can download the collection jar to get it without building any code, and there are many posts discussing its use:
> 
> Richard

Hi

This is the answer and you need to configure it like this.

Anything that you have added you need to strip it out if it doesn’t work, effectively testing each element as you go so that you know which is failing. (The last 1 you added).

Jason

---

<div class="post-metadata">

**Author:** ![Jason\_Hilton](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/jason_hilton/32/437_2.png) [@Jason\_Hilton](https://community.wowza.com/u/Jason_Hilton)\
**Post date:** [October 31, 2011, 11:22am UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/10 "2011-10-31T11:22:30Z")

</div>

Hi

Yes this is correct but this,

Caused by: java.lang.NoSuchMethodError: com.wowza.wms.stream.publish.Stream.setSendOnMetad ata(Z)V

Is usually caused by an incorrect version of Wowza or ServerListenerStreamPublisher but the above seams to be correct.

You also have,

log4j:ERROR Failed to excute sql,

com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorEx ception: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘Stream1’’, ‘-’, ‘-’, ‘-’, ‘33.277’, ‘-’, ‘-’, ‘-’, ‘-’, ‘-’, ‘-’, ‘-’, ‘-’, ‘-’,’ at line 1

This is a major issue that you need to get resolved before you try to get any extra parts working.

Jason

---

<div class="post-metadata">

**Author:** ![Jason\_Hilton](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/jason_hilton/32/437_2.png) [@Jason\_Hilton](https://community.wowza.com/u/Jason_Hilton)\
**Post date:** [October 31, 2011, 3:43pm UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/11 "2011-10-31T15:43:33Z")

</div>

> then what should i do for better result
> 
> My Wowza Version is Wowza Media Server 2 for Amazon EC2 2.1.1 build24490

Hi

You said it was this at the top of this thread,

"Configure logging: file:///usr/local/WowzaMediaServer/conf/log4j.properties

INFO server server-start Wowza Media Server 3 Trial Edition (Expires: Nov 21, 2011) 3.0.2 build866 -

INFO server comment - Server License Key: SVRT3-XXXXX-XXXXX-XXXXX-XXXXX-yb9Kf"

Jason

---

<div class="post-metadata">

**Author:** ![Jason\_Hilton](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/jason_hilton/32/437_2.png) [@Jason\_Hilton](https://community.wowza.com/u/Jason_Hilton)\
**Post date:** [November 3, 2011, 1:00pm UTC](https://community.wowza.com/t/how-to-create-dynamic-playlist/36177/12 "2011-11-03T13:00:54Z")

</div>

Hi

I believe that this only works on WMS 2.2.4+

I suggest that your best bet is to upgrade your system or move to EC2 2.2.4

Jason
