# ERROR: Server.xml not found: exiting.

**URL:** <https://community.wowza.com/t/error-server-xml-not-found-exiting/34099>\
**Category:** Wowza Streaming Engine\
**Created:** [January 5, 2010, 10:49am UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099 "2010-01-05T10:49:40Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ian\_Smith](https://avatars.discourse-cdn.com/v4/letter/i/9f8e36/32.png) [@Ian\_Smith](https://community.wowza.com/u/Ian_Smith)\
**Post date:** [January 5, 2010, 10:49am UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/1 "2010-01-05T10:49:40Z")

</div>

I just installed Wowza on a fresh Ubuntu Server machine. I am trying to run ./startup.sh for the first time but when I do I get “ERROR: Server.xml not found: exiting.” I followed the two step process for running the install script and java is installed.

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [January 5, 2010, 3:56pm UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/2 "2010-01-05T15:56:15Z")

</div>

That is odd, something went wrong. I would just start over: uninstall, then re-install.

Richard

---

<div class="post-metadata">

**Author:** ![Charlie\_Good](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/charlie_good/32/383_2.png) [@Charlie\_Good](https://community.wowza.com/u/Charlie_Good)\
**Post date:** [January 5, 2010, 8:12am UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/3 "2010-01-05T08:12:05Z")

</div>

Which installer did you use (rpm, deb, tar)? I believe on your distro deb is the best choice. If you used tar then you can uninstall by executing the commands:

cd /usr/local

rm -rf WowzaMediaServer\*

Then I suggest downloading the deb installer and trying again.

Charlie

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [January 5, 2010, 4:11pm UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/4 "2010-01-05T16:11:35Z")

</div>

If you installed from RPM this should work:

```auto
sudo rpm –e WowzaMediaServer-2.0.0

```

Otherwise, refer to the Install section of the User Guide which includes different ways to install in different cases.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [January 5, 2010, 4:52pm UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/5 "2010-01-05T16:52:50Z")

</div>

Did you install as other user? Best to install as root.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [January 5, 2010, 5:24pm UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/6 "2010-01-05T17:24:21Z")

</div>

Does that mean that Wowza is effectively installed as root? Otherwise, see the “Run Server as Named User” section of the User Guide.

Richard

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [April 14, 2010, 7:24pm UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/7 "2010-04-14T19:24:18Z")

</div>

Look at the Project’s Build.xml, see if there is anything that needs to be adjusted there.

And open the Debug configuration dialog, and click on Arguments tab, check the VM Arguments box. If these are inaccurate, correct these.

Richard

---

<div class="post-metadata">

**Author:** ![Will\_Hetherington](https://avatars.discourse-cdn.com/v4/letter/w/db5fbb/32.png) [@Will\_Hetherington](https://community.wowza.com/u/Will_Hetherington)\
**Post date:** [February 4, 2010, 2:58pm UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/8 "2010-02-04T14:58:26Z")

</div>

I am guessing this deb was built for debian (funny that), where it works just fine; ubuntu does things a little differently in regards to root, it’s a debian based distro, but if your first exposure to linux was with ubuntu - you may be a tad confused with the behaviour.

[https://help.ubuntu.com/community/RootSudo](https://help.ubuntu.com/community/RootSudo)

After installing from the deb…

willwh@netromedia:~$ ls -al /usr/local/WowzaMediaServer-2.0.0/

total 284

drwxrwxr-x 11 root root 4096 2010-02-04 14:36 .

You’ll see from the above command that yes indeed, this dir is owned by root; as per rrlanham, check your user guide to be able to run this as a different user.

---

<div class="post-metadata">

**Author:** ![Ian\_Smith](https://avatars.discourse-cdn.com/v4/letter/i/9f8e36/32.png) [@Ian\_Smith](https://community.wowza.com/u/Ian_Smith)\
**Post date:** [January 5, 2010, 11:04am UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/9 "2010-01-05T11:04:14Z")

</div>

I did uninstall by rm’ing the Wowza dir in /usr/local and reinstalled but got the same error. Is there a more comprehensive uninstall method?

---

<div class="post-metadata">

**Author:** ![Ian\_Smith](https://avatars.discourse-cdn.com/v4/letter/i/9f8e36/32.png) [@Ian\_Smith](https://community.wowza.com/u/Ian_Smith)\
**Post date:** [January 5, 2010, 11:17am UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/10 "2010-01-05T11:17:10Z")

</div>

I did use the deb version for the installation.

rpm isn’t on the machine.

I’ll rm the wowza folders in local and try again.

---

<div class="post-metadata">

**Author:** ![Ian\_Smith](https://avatars.discourse-cdn.com/v4/letter/i/9f8e36/32.png) [@Ian\_Smith](https://community.wowza.com/u/Ian_Smith)\
**Post date:** [January 5, 2010, 11:23am UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/11 "2010-01-05T11:23:08Z")

</div>

Figured it out. I had to run /startup.sh as su.

---

<div class="post-metadata">

**Author:** ![Ian\_Smith](https://avatars.discourse-cdn.com/v4/letter/i/9f8e36/32.png) [@Ian\_Smith](https://community.wowza.com/u/Ian_Smith)\
**Post date:** [January 5, 2010, 11:32am UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/12 "2010-01-05T11:32:07Z")

</div>

Seems as though there is a permissions issue. When I try to cd to the conf dir I get permission denied.

---

<div class="post-metadata">

**Author:** ![Ian\_Smith](https://avatars.discourse-cdn.com/v4/letter/i/9f8e36/32.png) [@Ian\_Smith](https://community.wowza.com/u/Ian_Smith)\
**Post date:** [January 5, 2010, 11:55am UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/13 "2010-01-05T11:55:46Z")

</div>

I used sudo to install. Ubuntu’s root account is disabled by default.

---

<div class="post-metadata">

**Author:** ![Omu\_Omuleanu](https://avatars.discourse-cdn.com/v4/letter/o/958977/32.png) [@Omu\_Omuleanu](https://community.wowza.com/u/Omu_Omuleanu)\
**Post date:** [April 14, 2010, 10:31am UTC](https://community.wowza.com/t/error-server-xml-not-found-exiting/34099/14 "2010-04-14T10:31:32Z")

</div>

I have the same problem, I’m on Windows 7 Home Basic, I am able to run wowza using the command line: net start wowzamediaserver, but when I try to run it from wowza IDE I get " ERROR: Server.xml not found: exiting. " in the console
