# Could not connect to server: http://localhost:8087 - when trying to login to WSE

**URL:** https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009
**Category:** Wowza Streaming Engine
**Created:** [February 13, 2014, 8:10am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009 "2014-02-13T08:10:07Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![Steven\_Duff](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Steven\_Duff](https://community.wowza.com/u/Steven_Duff)
#### Post date: [February 13, 2014, 8:10am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/1 "2014-02-13T08:10:07Z")

</div>

Hello,

I have the user name and password when setup/install correct, but when trying to login to Wowza Streaming Engine Manager I get this error every time:

---

<div class="post-metadata">

### Author: ![Inderjeet\_S\_Sodhi](https://avatars.discourse-cdn.com/v4/letter/i/bbce88/32.png) [@Inderjeet\_S\_Sodhi](https://community.wowza.com/u/Inderjeet_S_Sodhi)
#### Post date: [February 15, 2014, 5:29am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/2 "2014-02-15T05:29:30Z")

</div>

> Hello,
> 
> I have the user name and password when setup/install correct, but when trying to login to Wowza Streaming Engine Manager I get this error every time: Could not connect to server: [http://localhost:8087](http://localhost:8087).

You haven’t mentioned your OS. Wowza SE 4.0.0 fails to start on Windows 32 bit after setup completes. Please [see my post](http://community.wowza.com/t/-/39749). This could also be the case if JRE is not the “server” version. Run the \bin\startup.bat file manually to see what error message shows. If that starts up the server fine, check if the service is getting started or not.

Sincerely,

Inderjeet

---

<div class="post-metadata">

### Author: ![sal\_jefferson](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@sal\_jefferson](https://community.wowza.com/u/sal_jefferson)
#### Post date: [February 13, 2014, 8:41am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/3 "2014-02-13T08:41:32Z")

</div>

Two possible issues here are:

Make sure Wowza is still running when trying to connect to admin panel. Or if you shut down Wowza, re-start then re-launch Wowza Streaming Engine Manager.

The other possibility is you are using a license for Wowza 3x? You will need a new license for Wowza 4.0

Salvadore

---

<div class="post-metadata">

### Author: ![Graeme\_Bull](https://avatars.discourse-cdn.com/v4/letter/g/cc9497/32.png) [@Graeme\_Bull](https://community.wowza.com/u/Graeme_Bull)
#### Post date: [July 29, 2015, 9:03am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/4 "2015-07-29T09:03:58Z")

</div>

I’m having this issue just recently as well after installing IIS on the same server and separating off IP addresses.

I have done the following:

Applied a specific IP to both IIS and Wowza

Ensured both bind to their own and don’t try to bind to the others. Wowza’s log shows this (IP address taken out, safe to assume it’s correct):

INFO server comment - RESTServer: Bind attempt ([\*\*\*\*\*\*\*\*\*\*\*]:8087)

INFO server comment - RESTServer: Bind successful ([\*\*\*\*\*\*\*\*\*\*\*]:8087)

So I know the admin service can bind fine.

In the Server.xml file I have added that particular IP, localhost and 127.0.0.1 to the whitelist section of the 8087 port area.

Whether I access the service manager through either the 127.0.0.1 or the actual IP that I set for the 8088 service (and streaming services), I get the error:

* * *

Wowza Streaming Engine Manager could not connect to the Wowza Steaming Engine ([http://localhost:8087](http://localhost:8087)). Verify that the Wowza Streaming Engine service has started and is running.

* * *

Yes, that’s a typo guys… It’s not a “Wowza Steaming Engine”, but I digress. It’s still accessing the localhost for the 8087 service when it’s clearly bound to the IP. Not sure if that matters as this next error shows up (removed IP for security purposes):

* * *

Jul 29, 2015 11:55:10 AM org.restlet.ext.httpclient.internal.HttpMethodCall send

Request

WARNING: An error occurred during the communication with the remote HTTP server.

org.apache.http.conn.HttpHostConnectException: Connection to http://\*\*\*\*\*\*\*\*\*:8087 refused

at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnect

ion(DefaultClientConnectionOperator.java:190)

at org.apache.http.impl.conn.AbstractPoolEntry.open(AbstractPoolEntry.ja

va:151)

at org.apache.http.impl.conn.AbstractPooledConnAdapter.open(AbstractPool

edConnAdapter.java:125)

at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(Default

RequestDirector.java:643)

at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultReq

uestDirector.java:479)

at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpCl

ient.java:906)

at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpCl

ient.java:805)

at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpCl

ient.java:784)

at org.restlet.ext.httpclient.internal.HttpMethodCall.sendRequest(HttpMe

thodCall.java:347)

at org.restlet.engine.adapter.ClientAdapter.commit(ClientAdapter.java:11

1. 

at org.restlet.engine.adapter.HttpClientHelper.handle(HttpClientHelper.j

ava:112)

at org.restlet.Client.handle(Client.java:162)

at org.restlet.routing.Filter.doHandle(Filter.java:159)

at org.restlet.routing.Filter.handle(Filter.java:206)

at org.restlet.resource.ClientResource.handle(ClientResource.java:1104)

at org.restlet.resource.ClientResource.handleOutbound(ClientResource.jav

a:1188)

at org.restlet.resource.ClientResource.handle(ClientResource.java:1059)

at org.restlet.resource.ClientResource.handle(ClientResource.java:1035)

at org.restlet.resource.ClientResource.handle(ClientResource.java:937)

at org.restlet.resource.ClientResource.get(ClientResource.java:645)

at com.wowza.wms.rest.WMSClientResource.get(Unknown Source)

at com.wowza.wms.rest.server.ServerConfig.getObjectFromRESTQuietly(Unkno

wn Source)

at com.wowza.wms.rest.restserver.RESTServer.a(Unknown Source)

at com.wowza.wms.rest.restserver.RESTServer.a(Unknown Source)

at com.wowza.wms.rest.restserver.RESTServer$1.run(Unknown Source)

at java.lang.Thread.run(Thread.java:745)

Caused by: java.net.ConnectException: Connection refused: connect

at java.net.TwoStacksPlainSocketImpl.socketConnect(Native Method)

at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.ja

va:345)

at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocket

Impl.java:206)

at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java

:188)

at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)

at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)

at java.net.Socket.connect(Socket.java:589)

at org.apache.http.conn.scheme.PlainSocketFactory.connectSocket(PlainSoc

ketFactory.java:127)

at org.apache.http.conn.scheme.PlainSocketFactory.connectSocket(PlainSoc

ketFactory.java:184)

at org.apache.http.conn.scheme.SchemeSocketFactoryAdaptor.connectSocket(

SchemeSocketFactoryAdaptor.java:65)

at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnect

ion(DefaultClientConnectionOperator.java:180)

… 25 more

* * *

So how do I fix this?

---

<div class="post-metadata">

### Author: ![Graeme\_Bull](https://avatars.discourse-cdn.com/v4/letter/g/cc9497/32.png) [@Graeme\_Bull](https://community.wowza.com/u/Graeme_Bull)
#### Post date: [July 29, 2015, 9:29am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/5 "2015-07-29T09:29:12Z")

</div>

Thanks for the thoughts. Yes, I tried just 8087 and it says nothing is running. As the bind worked ok, I would expect that there is nothing else trying to bind to that port.

I was testing on the machine itself, I wouldn’t expect the firewall to have any effect. As this wasn’t happening before changing the IP to a specific one (by default it’s set to localhost), I expect there is something else I’m missing or a bug.

---

<div class="post-metadata">

### Author: ![Graeme\_Bull](https://avatars.discourse-cdn.com/v4/letter/g/cc9497/32.png) [@Graeme\_Bull](https://community.wowza.com/u/Graeme_Bull)
#### Post date: [July 29, 2015, 11:50am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/6 "2015-07-29T11:50:10Z")

</div>

Hi Inderjeet

Thanks for the response. I can say that everything else is working as expected. As it shows in the logs, the connection to the 8087 port is being refused. I just need to be able to fix that. I’ve done pretty much everything you have suggested, thank you though.

---

<div class="post-metadata">

### Author: ![Graeme\_Bull](https://avatars.discourse-cdn.com/v4/letter/g/cc9497/32.png) [@Graeme\_Bull](https://community.wowza.com/u/Graeme_Bull)
#### Post date: [July 30, 2015, 10:16am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/7 "2015-07-30T10:16:58Z")

</div>

Is there anybody from Wowza that can chime in on this? I’ve seen a few threads on the forum on this issue and none of them have been resolved or shown resolution to the problem.

---

<div class="post-metadata">

### Author: ![Jason\_Hilton](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/jason_hilton/32/437_2.png) [@Jason\_Hilton](https://community.wowza.com/u/Jason_Hilton)
#### Post date: [February 18, 2014, 4:40pm UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/8 "2014-02-18T16:40:22Z")

</div>

Hi,

That’s great news, I’m glad it’s working for you.

Thanks for the update.

Jason

---

<div class="post-metadata">

### Author: ![Tim\_Dougherty](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/tim_dougherty/32/596_2.png) [@Tim\_Dougherty](https://community.wowza.com/u/Tim_Dougherty)
#### Post date: [February 14, 2014, 6:44pm UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/9 "2014-02-14T18:44:05Z")

</div>

Hello,

Thank you for the feedback on these issues. Please let me offer some suggestions:

> I have the user name and password when setup/install correct, but when trying to login to Wowza Streaming Engine Manager I get this error every time: Could not connect to server: [http://localhost:8087](http://localhost:8087).

This may be the result of connecting to a Wowza instance that is running in a hosted/data center environment. Try adding your IP address to the whitelist settings using these instructions from the [**Quick Start Guide**](https://www.wowza.com/docs/how-to-install-and-configure-wowza-streaming-engine#whitelist).

> Upon startup, WME fails to load. The Manager does load. The following error is seen in the Event Viewer:
> 
> Service WowzaStreamingEngineManager400 received unsupported INTERROGATE control, which will not be handled.

Functionally, Wowza Streaming Engine Manager (WSEM) operates in parallel with Wowza Streaming Engine (WSE). It looks like WSE is starting without the WSEM. Try a specific startup sequence to see if that helps the situation. Please refer to these instructions for specifics on how to (1) start Wowza Streaming Engine and then (2) Wowza Streaming Engine Manager.

- [**How to start/stop WSE**](https://www.wowza.com/docs/how-to-install-and-configure-wowza-streaming-engine#startServer)

- [**How to start/stop WSE Manager**](https://www.wowza.com/docs/how-to-install-and-configure-wowza-streaming-engine#startManager)

1. Using the instructions from the QuickStart Guide, try manually starting Wowza as a service.

2. Confirm that Wowza Streaming Engine is running by testing this URL, in a web browser, which should return some version information:

http://[wowza-ip-address]:1935

1. Start Wowza Streaming Engine Manager

2. Access Wowza Stream Manager using this URL and attempt to login:

http://[wowza-ip-address]:8088

If these issues persist, please create a support ticket by sending an email to **support@wowza.com**. Please include a reference to this post and attach the following as a .zip (or other archive):

**[install-dir]/conf**

**[install-dir]/logs**

**[install-dir]/manager/logs**

We are very excited with this new release and look forward to hearing from you.

Please keep us posted.

-Tim

---

<div class="post-metadata">

### Author: ![Tim\_Dougherty](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/tim_dougherty/32/596_2.png) [@Tim\_Dougherty](https://community.wowza.com/u/Tim_Dougherty)
#### Post date: [February 21, 2014, 2:29pm UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/10 "2014-02-21T14:29:22Z")

</div>

Riccardo,

We did have another FreeBSD user who reported that he was using OpenJDK6 / OpenJDK7 as binary package. He removed all the binary packages and recompiled OpenJDK7 from the source, which helped a great deal.

I am not sure if this applies to this issue, but it is worth a try. We tend to not support Wowza on FreeBSD, but are aware that integration on that platform is possible.

-Tim

---

<div class="post-metadata">

### Author: ![Inderjeet\_S\_Sodhi](https://avatars.discourse-cdn.com/v4/letter/i/bbce88/32.png) [@Inderjeet\_S\_Sodhi](https://community.wowza.com/u/Inderjeet_S_Sodhi)
#### Post date: [July 29, 2015, 10:40pm UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/11 "2015-07-29T22:40:04Z")

</div>

Hi,

First things first,

1. have you tried to open [http://yourIP:8087](http://yourIP:8087) and see if anything is running already there?

2. If yes, that is conflicting, obviously. If not, have you disabled the firewall temporarily just to test?

Regards

Inderjeet

---

<div class="post-metadata">

### Author: ![Inderjeet\_S\_Sodhi](https://avatars.discourse-cdn.com/v4/letter/i/bbce88/32.png) [@Inderjeet\_S\_Sodhi](https://community.wowza.com/u/Inderjeet_S_Sodhi)
#### Post date: [July 29, 2015, 11:57pm UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/12 "2015-07-29T23:57:26Z")

</div>

You did not mention the version, so I presume its 4.2 and that you’ve changed the IP from the Wowza streaming engine manager interface. From what I have observed in the past, this message you’re stating comes when the streaming engine manager cannot connect to Wowza server.

Have you done any changes in VHost.xml? Is Wowza server running? Can you connect to ports 8086 and 1935? If you start Wowza on command prompt does it start and if not, what does it say? Needless to mention, please restart the Wowza service or stop it and run as standalone while testing. Then perhaps some more details can be caught.

Best wishes

Inderjeet

---

<div class="post-metadata">

### Author: ![sal\_jefferson](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@sal\_jefferson](https://community.wowza.com/u/sal_jefferson)
#### Post date: [February 10, 2015, 6:47am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/13 "2015-02-10T06:47:51Z")

</div>

Hello there and welcome to the Wowza support forum.

Please follow this guide to shut Wowza down, and then restart in standalone mode:

[How to start and stop Wowza Streaming Engine software](https://www.wowza.com/docs/how-to-start-and-stop-wowza-streaming-engine-software)

Starting Wowza in standalone mode will display the server output to the console and show any start-up issues, bind errors etc…

Please let us know what you see in the console output when restarting Wowza in standalone mode.

Kind regards,

Salvadore

---

<div class="post-metadata">

### Author: ![sal\_jefferson](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@sal\_jefferson](https://community.wowza.com/u/sal_jefferson)
#### Post date: [February 10, 2015, 10:02am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/14 "2015-02-10T10:02:16Z")

</div>

I[posted a reply to your thread](https://www.wowza.com/forums/showthread.php?36168-Output-an-MPEG-TS-stream-over-UDP-in-a-multicast-network&p=150188&posted=1#post150188) Mausspb.

Please try to keep other threads on topic.

Thanks,

Salvadore

---

<div class="post-metadata">

### Author: ![sal\_jefferson](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@sal\_jefferson](https://community.wowza.com/u/sal_jefferson)
#### Post date: [November 18, 2015, 7:07am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/15 "2015-11-18T07:07:52Z")

</div>

Hello megame. As mentioned by Michelle above, if you have tried all suggestions and still having an issue please open a ticket with support by zipping your /conf and /logs folders and sending them to support@wowza.com

Regards,

Salvadore

---

<div class="post-metadata">

### Author: ![Kyle\_Zimmerman](https://avatars.discourse-cdn.com/v4/letter/k/ce7236/32.png) [@Kyle\_Zimmerman](https://community.wowza.com/u/Kyle_Zimmerman)
#### Post date: [February 14, 2014, 4:37pm UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/16 "2014-02-14T16:37:21Z")

</div>

I’m having the same problem.

I ununstalled Wowza 3.x and installed a fresh copy of WME 4. I haven’t configured anything.

Upon startup, WME fails to load. The Manager does load. The following error is seen in the Event Viewer:

Service WowzaStreamingEngineManager400 received unsupported INTERROGATE control, which will not be handled.

Any ideas?

---

<div class="post-metadata">

### Author: ![Kyle\_Zimmerman](https://avatars.discourse-cdn.com/v4/letter/k/ce7236/32.png) [@Kyle\_Zimmerman](https://community.wowza.com/u/Kyle_Zimmerman)
#### Post date: [February 18, 2014, 9:16am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/17 "2014-02-18T09:16:56Z")

</div>

I forgot to specify the proxy server in the new install. Thank you for the help and sorry for wasting time.

Running startup.bat for the command line returned a messaged stating that the license server couldn’t be reached. I also performed a packet capture to confirm that the requested was being blocked because a proxy was not specified.

Thanks again for the help.

---

<div class="post-metadata">

### Author: ![J\_van\_Marion](https://avatars.discourse-cdn.com/v4/letter/j/dc4da7/32.png) [@J\_van\_Marion](https://community.wowza.com/u/J_van_Marion)
#### Post date: [February 13, 2014, 8:20pm UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/18 "2014-02-13T20:20:59Z")

</div>

A little more info about the steps you did will make it easier to answer your questions. Just to make sure people dont give possible solutions you might already have tried.

---

<div class="post-metadata">

### Author: ![Ray\_Mahangoe](https://avatars.discourse-cdn.com/v4/letter/r/58956e/32.png) [@Ray\_Mahangoe](https://community.wowza.com/u/Ray_Mahangoe)
#### Post date: [February 19, 2014, 10:16am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/19 "2014-02-19T10:16:29Z")

</div>

> Hello,
> 
> Thank you for the feedback on these issues. Please let me offer some suggestions:
> 
> This may be the result of connecting to a Wowza instance that is running in a hosted/data center environment. Try adding your IP address to the whitelist settings using these instructions from the [**Quick Start Guide**](https://www.wowza.com/docs/how-to-install-and-configure-wowza-streaming-engine#whitelist).
> 
> Functionally, Wowza Streaming Engine Manager (WSEM) operates in parallel with Wowza Streaming Engine (WSE). It looks like WSE is starting without the WSEM. Try a specific startup sequence to see if that helps the situation. Please refer to these instructions for specifics on how to (1) start Wowza Streaming Engine and then (2) Wowza Streaming Engine Manager.
> 
> - [**How to start/stop WSE**](https://www.wowza.com/docs/how-to-install-and-configure-wowza-streaming-engine#startServer)
> 
> - [**How to start/stop WSE Manager**](https://www.wowza.com/docs/how-to-install-and-configure-wowza-streaming-engine#startManager)
> 
> 1. Using the instructions from the QuickStart Guide, try manually starting Wowza as a service.
> 
> 2. Confirm that Wowza Streaming Engine is running by testing this URL, in a web browser, which should return some version information:
> 
> http://[wowza-ip-address]:1935
> 
> 1. Start Wowza Streaming Engine Manager
> 
> 2. Access Wowza Stream Manager using this URL and attempt to login:
> 
> http://[wowza-ip-address]:8088
> 
> If these issues persist, please create a support ticket by sending an email to **support@wowza.com**. Please include a reference to this post and attach the following as a .zip (or other archive):
> 
> **[install-dir]/conf**
> 
> **[install-dir]/logs**
> 
> **[install-dir]/manager/logs**
> 
> We are very excited with this new release and look forward to hearing from you.
> 
> Please keep us posted.
> 
> -Tim

* * *

Hi Tim,

i’ve just installed a fresh new installation of wowza on FreeBSD 10.0-RELEASE.🆒

had to edit some shell script, but after that the installation when flawless…😉

Im now connecting with a pc to this Wowza server and for the first time i got a welcome wizard.

after this wizard i had to login with the admin user i make during the installation.

When i try to login i got this error message.

WARN rest REST API: Authentication: Could not access server:[http://localhost:8087:](http://localhost:8087:)

The ip of the server is 10.65.18.40

As well as the Manager as the Engine are running.

**Netstat show’s:**

_tcp4 0 0 amcmnv01.chellom.8088 amcmws480.chello.49226 TIME\_WAIT_

_tcp4 0 0 amcmnv01.chellom.8088 amcmws480.chello.49225 TIME\_WAIT_

_tcp4 0 0 amcmnv01.chellom.8088 amcmws480.chello.49223 TIME\_WAIT_

_tcp4 0 0 amcmnv01.chellom.8088 amcmws480.chello.49222 TIME\_WAIT_

_tcp46 0 0 \*.8009 . LISTEN_

_tcp46 0 0 \*.8088 . LISTEN_

_tcp4 0 0 \*.8086 . LISTEN_

_tcp4 0 0 \*.1935 . LISTEN_

_tcp4 0 0 \*.8083 . LISTEN_

_tcp4 0 0 \*.8087 . LISTEN_

_ **Log file show’s:** _

_INFO server comment - Server runmode: standalone_

_INFO server comment - Server native.platform: linux_

_INFO server comment - Server threads[h/t]: 360/240_

_INFO server comment - RESTServer: Bind attempt ([any]:8087)_

_INFO server comment - RESTServer: Bind successful ([any]:8087)_

_INFO server comment - RESTServer: Using configs from:/usr/local/WowzaStreamingEngine/_

_INFO server comment - RESTServer: SSL:No_

_INFO server comment - RESTServer: BasicAuth:No_

_INFO server comment - RESTServer: Digest:Yes_

_INFO server comment - RESTServer: XML Viewer:No_

_INFO server comment - Wowza REST API started_

_INFO server comment - CMDInterface now listening: [any]:8083_

_INFO server comment - MediaCache[MediaCache]: Thread pool size: [writer/readahead]:12/6_

_INFO server comment - MediaCache[MediaCache]: MAX Pending size: [writer/readahead]:500M/25M_

_INFO server comment - MediaCache[MediaCache]: Add store: path:/usr/local/WowzaStreamingEngine/mediacache maxSize:10737418240_

_INFO server comment - MediaCache[MediaCache]: Add source[dvrorigin]: prefix:dvrorigin/ basePath:http://_

_INFO server comment - MediaCache[MediaCache]: Flushing cache: start_

_INFO server comment - MediaCache[MediaCache]: Flushing cache: done_

_INFO server comment - MediaCache[MediaCache]: Start MediaCache GC_

_INFO server comment - MediaCache[MediaCache]: Started_

_INFO vhost vhost-start defaultVHost -_

_INFO server comment - defaultVHost threads[h/t]:0/0 home:/usr/local/WowzaStreamingEngine_

_INFO vhost comment defaultVHost Bind attempt ([any]:1935:12)_

_INFO vhost comment defaultVHost Bind successful ([any]:1935)_

_INFO vhost comment defaultVHost Bind attempt ([any]:8086:4)_

_INFO vhost comment defaultVHost Bind successful ([any]:8086)_

_INFO server comment - Server.startShutdownHook: Start server shutdown hook_

_INFO server comment - StatsManager:startManager() Enabled=true_

_INFO server comment - Wowza Streaming Engine is started!_

_ **Java error:** _

_2014-02-19 11:06:38,778 [RequestHandlerThread[15]] ERROR net.winstone.core.listener.RequestHandlerThread - Socket read timed out - exiting request handler thread_

_java.net.SocketTimeoutException: Read timed out_

_at java.net.SocketInputStream.socketRead0(Native Method)_

_at java.net.SocketInputStream.read(SocketInputStream.java:146)_

_at java.net.SocketInputStream.read(SocketInputStream.java:199)_

_at net.winstone.core.WinstoneInputStream.read(WinstoneInputStream.java:56)_

_at javax.servlet.ServletInputStream.readLine(ServletInputStream.java:104)_

_at net.winstone.core.WinstoneInputStream.readLine(WinstoneInputStream.java:121)_

_at net.winstone.core.listener.HttpListener.parseURI(HttpListener.java:240)_

_at net.winstone.core.listener.RequestHandlerThread.run(RequestHandlerThread.java:91)_

_at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)_

_at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)_

_at java.util.concurrent.FutureTask.run(FutureTask.java:166)_

_at net.winstone.util.BoundedExecutorService$1.run(BoundedExecutorService.java:81)_

_at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)_

_at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)_

_at java.lang.Thread.run(Thread.java:701)_

_WARN rest REST API: Authentication: Could not access server:[http://localhost:8087:](http://localhost:8087:)_

_Any idea …_

---

<div class="post-metadata">

### Author: ![Riccardo\_De\_Menna](https://avatars.discourse-cdn.com/v4/letter/r/919ad9/32.png) [@Riccardo\_De\_Menna](https://community.wowza.com/u/Riccardo_De_Menna)
#### Post date: [February 21, 2014, 9:13am UTC](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009/20 "2014-02-21T09:13:19Z")

</div>

Hi Tim,

I have the same issue that rmahangoe has. In my case FreeBSD9.0-RELEASE. Everything looks fine but the manager can’t authenticate.

If I manually connect to port 8087 via browser, I’m requested user and password and after submission I see the standard one-line-info for the server.

On port 8088 I get the manager’s interface that leads me to the login panel but then it fails authentication as per rmahangoe’s post.

The manager’s logs show the failed attempt. The server log shows absolutely nothing as if the request had never even reached the server (as in a wrong URL).

Any help would be great,

rdm

[Next page](https://community.wowza.com/t/could-not-connect-to-server-http-localhost-8087-when-trying-to-login-to-wse/42009.md?page=2)
