# com.wowza.wms.runmode standalone or service or something else?

**URL:** <https://community.wowza.com/t/com-wowza-wms-runmode-standalone-or-service-or-something-else/34224>\
**Category:** Wowza Streaming Engine\
**Tags:** server-administration\
**Created:** [April 18, 2012, 10:17am UTC](https://community.wowza.com/t/com-wowza-wms-runmode-standalone-or-service-or-something-else/34224 "2012-04-18T10:17:36Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Andrey\_Sokolov](https://avatars.discourse-cdn.com/v4/letter/a/e36b37/32.png) [@Andrey\_Sokolov](https://community.wowza.com/u/Andrey_Sokolov)\
**Post date:** [April 18, 2012, 10:17am UTC](https://community.wowza.com/t/com-wowza-wms-runmode-standalone-or-service-or-something-else/34224/1 "2012-04-18T10:17:36Z")

</div>

Hello Wowza Team!

com.wowza.wms.runmode=“standalone”, com.wowza.wms.runmode=“service”

What is difference?

Could you please describe this options and and what other options are possible?

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [April 18, 2012, 2:28pm UTC](https://community.wowza.com/t/com-wowza-wms-runmode-standalone-or-service-or-something-else/34224/2 "2012-04-18T14:28:20Z")

</div>

You can run Wowza in stand-alone mode: /bin/startup.bat (or startup.sh). This is a good idea during testing and development because you can see log output in the console immediately.

Run Wowza as a service in production so that it starts when the machine reboots.

Richard

---

<div class="post-metadata">

**Author:** ![Roger\_Littin1](https://avatars.discourse-cdn.com/v4/letter/r/c89c15/32.png) [@Roger\_Littin1](https://community.wowza.com/u/Roger_Littin1)\
**Post date:** [July 22, 2014, 8:11am UTC](https://community.wowza.com/t/com-wowza-wms-runmode-standalone-or-service-or-something-else/34224/3 "2014-07-22T08:11:24Z")

</div>

Hi,

That error occurs when there is a different java version running on the development environment compared to the proiduction environment. The development version is too new compared to the production version.

Roger.

---

<div class="post-metadata">

**Author:** ![Guilherme\_Nozawa](https://avatars.discourse-cdn.com/v4/letter/g/34f0e0/32.png) [@Guilherme\_Nozawa](https://community.wowza.com/u/Guilherme_Nozawa)\
**Post date:** [July 21, 2014, 10:33am UTC](https://community.wowza.com/t/com-wowza-wms-runmode-standalone-or-service-or-something-else/34224/4 "2014-07-21T10:33:43Z")

</div>

Error starting: java.lang.reflect.InvocationTargetException

java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:606)

at com.wowza.wms.bootstrap.Bootstrap.startServer(Bootstrap.java:555)

at com.wowza.wms.bootstrap.Bootstrap.main(Bootstrap.java:67)

Caused by: java.lang.UnsupportedClassVersionError: com/[company\_name]/wms/httpprovider/StreamingRequest : Unsupported major.minor version 52.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClass(ClassLoader.java:800)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14 2)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)

at java.net.URLClassLoader.access$100(URLClassLoader.java:71)

at java.net.URLClassLoader$1.run(URLClassLoader.java:361)

at java.net.URLClassLoader$1.run(URLClassLoader.java:355)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:354)

at java.lang.ClassLoader.loadClass(ClassLoader.java:425)

at java.lang.ClassLoader.loadClass(ClassLoader.java:358)

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Class.java:190)

at com.wowza.wms.util.VHostUtils.loadHTTPProvider(VHostUtils.java:61)

at com.wowza.wms.util.VHostUtils.loadHostPort(VHostUtils.java:609)

at com.wowza.wms.util.VHostUtils.loadHostPortList(VHostUtils.java:686)

at com.wowza.wms.util.VHostUtils.loadConfigFile(VHostUtils.java:978)

at com.wowza.wms.vhost.VHost.c(VHost.java:1185)

at com.wowza.wms.vhost.VHost.init(VHost.java:501)

at com.wowza.wms.vhost.VHostSingleton.init(VHostSingleton.java:62)

at com.wowza.wms.server.Server.startVHost(Server.java:2215)

at com.wowza.wms.server.Server.startVHosts(Server.java:2764)

at com.wowza.wms.server.Server.start(Server.java:1006)

… 6 more

I see that the error are happening in HTTP Provider created by me. But i create in a development environment with the same Wowza version. What would be a “major.minor version 52.0” error?
