# Bind failed: (\[any\]:80): java.net.SocketException: Permission denied

**URL:** <https://community.wowza.com/t/bind-failed-any-80-java-net-socketexception-permission-denied/35518>\
**Category:** Wowza Streaming Engine\
**Created:** [March 1, 2011, 11:36am UTC](https://community.wowza.com/t/bind-failed-any-80-java-net-socketexception-permission-denied/35518 "2011-03-01T11:36:53Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Erik\_Luyten](https://avatars.discourse-cdn.com/v4/letter/e/df705f/32.png) [@Erik\_Luyten](https://community.wowza.com/u/Erik_Luyten)\
**Post date:** [March 1, 2011, 11:36am UTC](https://community.wowza.com/t/bind-failed-any-80-java-net-socketexception-permission-denied/35518/1 "2011-03-01T11:36:53Z")

</div>

When I try to activate port 80 I get a “Permission denied” warning.

I’m logged into the Mac OSX 10.6.6 as the only user on the system and have admin rights. I configured the /Library/WowzaMediaServer-2.2.3/conf/VHost.xml file as requested.

When I startup the server with the Wowza Startup app all requested ports are bound except port 80 with the Permission denied warning. The same happens if I use command line and startup.sh in the bin directory. When i use sudo ./startup.sh port 80 will bind.

Where do I set permissions so port 80 will bind without have to use sudo ?

> >

INFO server comment - _defaultVHost_ threads[h/t]:120/80 home:/Library/WowzaMediaServer

INFO vhost comment _defaultVHost_ Bind attempt ([any]:1935:4)

INFO vhost comment _defaultVHost_ Bind successful ([any]:1935)

INFO vhost comment _defaultVHost_ Bind attempt ([any]:80:4)

WARN vhost comment _defaultVHost_ Bind failed: ([any]:80): java.net.SocketException: Permission denied

INFO vhost comment _defaultVHost_ Bind attempt ([any]:8086:1)

INFO vhost comment _defaultVHost_ Bind successful ([any]:8086)

INFO server comment - Wowza Media Server is started!

\<\<

---

<div class="post-metadata">

**Author:** ![Andrew\_Kennedy](https://avatars.discourse-cdn.com/v4/letter/a/ecb155/32.png) [@Andrew\_Kennedy](https://community.wowza.com/u/Andrew_Kennedy)\
**Post date:** [March 1, 2011, 3:00am UTC](https://community.wowza.com/t/bind-failed-any-80-java-net-socketexception-permission-denied/35518/2 "2011-03-01T03:00:10Z")

</div>

I believe any port below 1024 requires the process to be running as root/admin.

Shamrock

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [May 25, 2013, 3:03pm UTC](https://community.wowza.com/t/bind-failed-any-80-java-net-socketexception-permission-denied/35518/3 "2013-05-25T15:03:04Z")

</div>

This indicates that there is a web server on that machine. If you can’t use 1935, 80 or 443, you might try 8080. You will have to use that port (or other alt port you determine will work) on every playback and publish url that you use with Wowza

Richard

---

<div class="post-metadata">

**Author:** ![ming\_tsai](https://avatars.discourse-cdn.com/v4/letter/m/13edae/32.png) [@ming\_tsai](https://community.wowza.com/u/ming_tsai)\
**Post date:** [February 18, 2013, 12:17am UTC](https://community.wowza.com/t/bind-failed-any-80-java-net-socketexception-permission-denied/35518/4 "2013-02-18T00:17:08Z")

</div>

use sudo to start wowza to avoid permission problem:

sudo sh startup.sh

---

<div class="post-metadata">

**Author:** ![Ramadhian\_Moestafa](https://avatars.discourse-cdn.com/v4/letter/r/6f9a4e/32.png) [@Ramadhian\_Moestafa](https://community.wowza.com/u/Ramadhian_Moestafa)\
**Post date:** [December 14, 2012, 12:21am UTC](https://community.wowza.com/t/bind-failed-any-80-java-net-socketexception-permission-denied/35518/5 "2012-12-14T00:21:43Z")

</div>

I have the same problem on my Fedora 17 …

running wowza service using root user , produce the same error

INFO server comment - Server runmode: standalone

INFO server comment - Server native.platform: linux

INFO server comment - Server threads[h/t]: 10/10

INFO server comment - CMDInterface now listening: [any]:8083

INFO vhost vhost-start _defaultVHost_ -

INFO server comment - _defaultVHost_ threads[h/t]:120/80 home:/usr/local/WowzaMediaServer

INFO vhost comment _defaultVHost_ Bind attempt ([any]:80:4)

WARN vhost comment _defaultVHost_ Bind failed: ([any]:80): java.net.SocketException: Permission denied

INFO vhost comment _defaultVHost_ Bind attempt ([any]:554:4)

WARN vhost comment _defaultVHost_ Bind failed: ([any]:554): java.net.SocketException: Permission denied

INFO vhost comment _defaultVHost_ Bind attempt ([any]:1935:4)

INFO vhost comment _defaultVHost_ Bind successful ([any]:1935)

INFO vhost comment _defaultVHost_ Bind attempt ([any]:8086:1)

INFO vhost comment _defaultVHost_ Bind successful ([any]:8086)

INFO server comment - Server.startShutdownHook: Start server shutdown hook

INFO server comment - Wowza Media Server is started!

80,554,1935 --\> vi VHost.xml

---

<div class="post-metadata">

**Author:** ![Roger\_Littin1](https://avatars.discourse-cdn.com/v4/letter/r/c89c15/32.png) [@Roger\_Littin1](https://community.wowza.com/u/Roger_Littin1)\
**Post date:** [December 14, 2012, 6:36am UTC](https://community.wowza.com/t/bind-failed-any-80-java-net-socketexception-permission-denied/35518/6 "2012-12-14T06:36:13Z")

</div>

Hi,

It looks like it is not actually the root user which is starting wowza. As Shamrock has mentioned, any port below 1024 requires root user to bind to it.

It could also be an seLinux permission problem.

What does the getenforce command return?

Try `setenforce 0` before starting Wowza.

Roger.

---

<div class="post-metadata">

**Author:** ![Damien\_Pascoe](https://avatars.discourse-cdn.com/v4/letter/d/7993a0/32.png) [@Damien\_Pascoe](https://community.wowza.com/u/Damien_Pascoe)\
**Post date:** [May 21, 2013, 11:42am UTC](https://community.wowza.com/t/bind-failed-any-80-java-net-socketexception-permission-denied/35518/7 "2013-05-21T11:42:57Z")

</div>

hey all im having the same problem here…

I have opened ports 80 and 443 through the vhost.xml and upon start up it comes back with the same error message…??

Can someone please give me some clear explanations on how to run these extra scripts to solve the permissions problem…?

Ps. I cant stream through 1935 my ISP wont give me port forwarding permissions… (it works fine but users cant see the stream.)
