# big log file size

**URL:** <https://community.wowza.com/t/big-log-file-size/41071>\
**Category:** Wowza Streaming Engine\
**Created:** [September 10, 2013, 7:23pm UTC](https://community.wowza.com/t/big-log-file-size/41071 "2013-09-10T19:23:09Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tony\_Germanos](https://avatars.discourse-cdn.com/v4/letter/t/dfb087/32.png) [@Tony\_Germanos](https://community.wowza.com/u/Tony_Germanos)\
**Post date:** [September 10, 2013, 7:23pm UTC](https://community.wowza.com/t/big-log-file-size/41071/1 "2013-09-10T19:23:09Z")

</div>

Dear all,

I am facing a problem with the log file. Each day a log file of about 7 GB (it reaches 11 GB sometimes) is created in the logs directory in wowza installation directory.

How can I stop writing everything to the log file and I didn’t add any module to the application.xml of the live?

Here is a sample of the logfile that is writting about 100 line each second (I noticed from the java window that appear when I open wowza startup). it was taken at 2 different times and separated by a line of \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*.

[http://pastebin.com/d8frikrR](http://pastebin.com/d8frikrR)

I have another server that I installed the wowza server on it making a ~40 MB logfile each day.

Can u help me understand what module is writing all this data and how to stop it?

Thanks

---

<div class="post-metadata">

**Author:** ![Richard\_Lanham](https://avatars.discourse-cdn.com/v4/letter/r/c68b51/32.png) [@Richard\_Lanham](https://community.wowza.com/u/Richard_Lanham)\
**Post date:** [September 10, 2013, 5:25pm UTC](https://community.wowza.com/t/big-log-file-size/41071/2 "2013-09-10T17:25:36Z")

</div>

You can comment out any or all of the appenders in the /conf/log4j.properties file.

Richard

---

<div class="post-metadata">

**Author:** ![Jin-mo\_Kang](https://avatars.discourse-cdn.com/v4/letter/j/3ec8ea/32.png) [@Jin-mo\_Kang](https://community.wowza.com/u/Jin-mo_Kang)\
**Post date:** [September 11, 2013, 10:37am UTC](https://community.wowza.com/t/big-log-file-size/41071/3 "2013-09-11T10:37:27Z")

</div>

You had to change the DEBUG option in the /conf/log4j.properties file and restart.

“log4j.rootCategory=DEBUG, stdout, serverAccess, serverError”

to

“log4j.rootCategory=INFO, stdout, serverAccess, serverError”

Jinmo Kang

---

<div class="post-metadata">

**Author:** ![Jin-mo\_Kang](https://avatars.discourse-cdn.com/v4/letter/j/3ec8ea/32.png) [@Jin-mo\_Kang](https://community.wowza.com/u/Jin-mo_Kang)\
**Post date:** [September 12, 2013, 2:35am UTC](https://community.wowza.com/t/big-log-file-size/41071/4 "2013-09-12T02:35:52Z")

</div>

See the c-ip field of access log files.

If you want to check in the console, just append the field to ‘c-ip’.

```auto
log4j.appender.stdout.layout.Fields=x-severity,x-category,x-event,x-ctx,x-comment,c-ip

```

---

<div class="post-metadata">

**Author:** ![Tony\_Germanos](https://avatars.discourse-cdn.com/v4/letter/t/dfb087/32.png) [@Tony\_Germanos](https://community.wowza.com/u/Tony_Germanos)\
**Post date:** [September 11, 2013, 6:04pm UTC](https://community.wowza.com/t/big-log-file-size/41071/5 "2013-09-11T18:04:27Z")

</div>

> You had to change the DEBUG option in the /conf/log4j.properties file and restart.
> 
> “log4j.rootCategory=DEBUG, stdout, serverAccess, serverError”
> 
> to
> 
> “log4j.rootCategory=INFO, stdout, serverAccess, serverError”
> 
> Jinmo Kang

Thanks I notice it with second server and change it before you replied but if I want to log the ips that are viewing the stream when the connect, how can I do it? I think it won’t make the logfile so big.

Thanks a lot guys.
