# 1.3.1 does not start as a Windows service

**URL:** https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156
**Category:** Wowza Streaming Engine
**Created:** [October 4, 2007, 5:39pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156 "2007-10-04T17:39:37Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![system](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/system/32/447_2.png) [@system](https://community.wowza.com/u/system)
#### Post date: [October 4, 2007, 5:39pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156/1 "2007-10-04T17:39:37Z")

</div>

If I try to start it as a service, I get "Could not start the Wowza Media Pro Server service on Local Computer. Error 1067: The process terminated unexpectedly.

The only log file I have is wowzamediaserverpro\_service.log and the mesages in there contain a repetive series of messages like:

STATUS | wrapper | 2007/10/04 09:15:08 | Wowza Media Server Pro installed.

STATUS | wrapper | 2007/10/04 10:03:24 | --\> Wrapper Started as Service

STATUS | wrapper | 2007/10/04 10:03:24 | Launching a JVM…

ERROR | wrapper | 2007/10/04 10:03:24 | JVM exited while loading the application.

STATUS | wrapper | 2007/10/04 10:03:29 | Launching a JVM…

ERROR | wrapper | 2007/10/04 10:03:29 | JVM exited while loading the application.

STATUS | wrapper | 2007/10/04 10:03:34 | Launching a JVM…

ERROR | wrapper | 2007/10/04 10:03:34 | JVM exited while loading the application.

STATUS | wrapper | 2007/10/04 10:03:38 | Launching a JVM…

ERROR | wrapper | 2007/10/04 10:03:39 | JVM exited while loading the application.

STATUS | wrapper | 2007/10/04 10:03:44 | Launching a JVM…

ERROR | wrapper | 2007/10/04 10:03:44 | JVM exited while loading the application.

FATAL | wrapper | 2007/10/04 10:03:44 | There were 5 failed launches in a row, each lasting less than 300 seconds. Giving up.

FATAL | wrapper | 2007/10/04 10:03:44 | There may be a configuration problem: please check the logs.

STATUS | wrapper | 2007/10/04 10:03:44 | \<-- Wrapper Stopped

If I run startup.bat, I error out in startenv.bat and get told that the WMSCONFIG\_HOME variable has a problem. It contains:

C:\Program Files\Wowza Media Systems\Wowza Media Server Pro 1.3.1\

I’m running on a Windows 2003 Server.

How do I fix the problem?

Best regards,

Michael Murray

---

<div class="post-metadata">

### Author: ![Charlie\_Good](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/charlie_good/32/383_2.png) [@Charlie\_Good](https://community.wowza.com/u/Charlie_Good)
#### Post date: [October 4, 2007, 3:22pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156/2 "2007-10-04T15:22:39Z")

</div>

It sounds like the install did not work correctly. Either uninstall and re-install or create the file:

C:\Program Files\Wowza Media Systems\Wowza Media Server Pro 1.3.1\conf\Server.license

and copy and paste your Pro10 license number into this file.

Charlie

---

<div class="post-metadata">

### Author: ![Charlie\_Good](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/charlie_good/32/383_2.png) [@Charlie\_Good](https://community.wowza.com/u/Charlie_Good)
#### Post date: [October 4, 2007, 3:33pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156/3 "2007-10-04T15:33:44Z")

</div>

Great!!!

Charlie

---

<div class="post-metadata">

### Author: ![Robert\_Smith](https://avatars.discourse-cdn.com/v4/letter/r/a183cd/32.png) [@Robert\_Smith](https://community.wowza.com/u/Robert_Smith)
#### Post date: [October 4, 2007, 6:00pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156/4 "2007-10-04T18:00:48Z")

</div>

There was a time I was spinning up test servers then dumping them and I’d get this now and then when I was tired and forgot to install the Java 1.6 JDK Before I installed wowza. Wowza would install but give that little message that it required java to run.

Sometimes even after installing the JDK I’d get the message you quoted when starting the wowza service OR starting the commandline server.

What I’d do is run the wowza uninstall then install the JDK then reinstall wowza … and reboot (to kick the java). After that my installs would be fine.

However if you are running 2003Server x64 then it might be that the Sun Windows Service shim had some issuyes with starting as a service under x64 I think because even though wowza is 64bit the shim is 32. Charlie can say whether that still is an issue.

---

<div class="post-metadata">

### Author: ![Charlie\_Good](https://sea2.discourse-cdn.com/flex002/user_avatar/community.wowza.com/charlie_good/32/383_2.png) [@Charlie\_Good](https://community.wowza.com/u/Charlie_Good)
#### Post date: [October 4, 2007, 3:08pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156/5 "2007-10-04T15:08:30Z")

</div>

Edit the two environment variables **WMSAPP\_HOME** and **WMSCONFIG\_HOME** and remove the trailing **/** character. That should fix it.

Charlie

---

<div class="post-metadata">

### Author: ![Robert\_Smith](https://avatars.discourse-cdn.com/v4/letter/r/a183cd/32.png) [@Robert\_Smith](https://community.wowza.com/u/Robert_Smith)
#### Post date: [October 4, 2007, 8:55pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156/6 "2007-10-04T20:55:12Z")

</div>

Disable the Windows service then go to the Start\>\>Programs\>\>Wowza and click on the “Wowza Pro Startup” to see the command line “dos box” version of the server. This will spew the status directly, same result?

Windows 2003 Server r2 x86, right?

And you have a full local box admin account, right?

Have to looked at the Windows Event Logs? Must be some reds there.

---

<div class="post-metadata">

### Author: ![Robert\_Smith](https://avatars.discourse-cdn.com/v4/letter/r/a183cd/32.png) [@Robert\_Smith](https://community.wowza.com/u/Robert_Smith)
#### Post date: [October 4, 2007, 11:17pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156/7 "2007-10-04T23:17:14Z")

</div>

That message is coming right from the logic in the C:\Program Files\Wowza Media Systems\Wowza Media Server Pro 1.3.1\bin\setenv.bat file.

Open that file in notepad and you’ll see how it’s checking for the location of the Server.license file off of the environment variables.

Is your server.license file where it is looking?

And if you right click on your MyComputer, then switch to the Advanced tab then press the button at the bottom labelled “Environment Variables” and scroll down the list of system variables do you see that you have these 3 environment variables:

WMSAPP\_HOME = C:\Program Files\Wowza Media Systems\Wowza Media Server Pro 1.3.1

WMSCONFIG\_HOME =

C:\Program Files\Wowza Media Systems\Wowza Media Server Pro 1.3.1

WMSINSTALL\_HOME = C:\Program Files\Wowza Media Systems\Wowza Media Server Pro 1.3.1\

I think Wowza sets these but I do recall having to set them manually once.

---

<div class="post-metadata">

### Author: ![Michael\_Murray](https://avatars.discourse-cdn.com/v4/letter/m/b2d939/32.png) [@Michael\_Murray](https://community.wowza.com/u/Michael_Murray)
#### Post date: [October 4, 2007, 6:43pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156/8 "2007-10-04T18:43:42Z")

</div>

You’re impression was correct. I installed Wowza Media Server, assuming that Java was on the server. Bad assumption. I installed JRE and the Java SDK for 1.6. I uninstalled and re-installed Wowza and I just re-booted. The log file has not changed:

STATUS | wrapper | 2007/10/04 12:22:33 | --\> Wrapper Started as Service

STATUS | wrapper | 2007/10/04 12:22:33 | Launching a JVM…

ERROR | wrapper | 2007/10/04 12:22:35 | JVM exited while loading the application.

STATUS | wrapper | 2007/10/04 12:22:40 | Launching a JVM…

ERROR | wrapper | 2007/10/04 12:22:40 | JVM exited while loading the application.

STATUS | wrapper | 2007/10/04 12:22:45 | Launching a JVM…

ERROR | wrapper | 2007/10/04 12:22:45 | JVM exited while loading the application.

STATUS | wrapper | 2007/10/04 12:22:50 | Launching a JVM…

ERROR | wrapper | 2007/10/04 12:22:50 | JVM exited while loading the application.

STATUS | wrapper | 2007/10/04 12:22:54 | Launching a JVM…

ERROR | wrapper | 2007/10/04 12:22:55 | JVM exited while loading the application.

FATAL | wrapper | 2007/10/04 12:22:55 | There were 5 failed launches in a row, each lasting less than 300 seconds. Giving up.

FATAL | wrapper | 2007/10/04 12:22:55 | There may be a configuration problem: please check the logs.

STATUS | wrapper | 2007/10/04 12:22:55 | \<-- Wrapper Stopped

Best regards,

Michael

---

<div class="post-metadata">

### Author: ![Michael\_Murray](https://avatars.discourse-cdn.com/v4/letter/m/b2d939/32.png) [@Michael\_Murray](https://community.wowza.com/u/Michael_Murray)
#### Post date: [October 4, 2007, 10:41pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156/9 "2007-10-04T22:41:36Z")

</div>

OK, the error message indicates a problem with the WMSCONFIG\_HOME environment variable. Same error as the last time I tried a manual start.

You can see an image of the error by [Clicking HERE](http://www.globalvideotech.com/images/wowzaproblem.jpg).

I checked the information on my server and it is Windows 2000 5.0.2195 Service Pack 4 on a dual processor Intel Xeon computer with 2 GB RAM.

Best regards,

Michael

---

<div class="post-metadata">

### Author: ![Michael\_Murray](https://avatars.discourse-cdn.com/v4/letter/m/b2d939/32.png) [@Michael\_Murray](https://community.wowza.com/u/Michael_Murray)
#### Post date: [October 4, 2007, 10:50pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156/10 "2007-10-04T22:50:05Z")

</div>

The only reds in there say

"The Wowza Media Server Pro service terminated unexpectedly. It has done this N time(s). The following corrective action will be taken in 0 milliseconds: No action. "

Where N is a cumulative number reflecting the number of times I tried to start the server.

Best regards,

Michael

---

<div class="post-metadata">

### Author: ![Michael\_Murray](https://avatars.discourse-cdn.com/v4/letter/m/b2d939/32.png) [@Michael\_Murray](https://community.wowza.com/u/Michael_Murray)
#### Post date: [October 4, 2007, 11:30pm UTC](https://community.wowza.com/t/1-3-1-does-not-start-as-a-windows-service/156/11 "2007-10-04T23:30:03Z")

</div>

Thanks Charlie,

I removed the trailing slashes and the server started. We’re rolling now, so I’m off to try it out and see what I can do with it.

Thanks again for your help.

Best regards,

Michael
